Indice

logoAsp.gif (1968 bytes)

AspToDba

rel. 2005

INDICE ARGOMENTI

Presentazione

Il database

Accesso ai files dati

Formato File Dati

Scarico dati da Internet

Abbinamento campi

Aggiornamenti manuali

Rettifiche e cancellazione dati


Abbinamento campi

Torna alla pagina iniziale

Abbinamento campi

Se i vostri files dati in entrata hanno sempre lo stesso formato l'attività qui illustrata dovrà essere svolta solo la prima volta che usate AspToDba. Il programma ricorderà l'ultima configurazione utilizzata.

Pannello di abbinamento campi

Il pannello "Abbinamento campi" serve per attribuire ad ogni colonna presente nel file dati in entrata il corretto significato in relazione alle necessità del database che andiamo ad aggiornare.

Quindi nei campi da 18 a 25 vediamo nella parte in alto i dati in entrata e nella riga più in basso la destinazione di questi dati nel database in uscita.

Pannello "Criteri" di separazione tra colonne del file in entrata

AspToDba, in base al criterio di separazione adottato, mostra come suddivide le colonne. I campi (da 18 a 25) prima della lettura del file dati sono tutti "No Data". Una volta scelto il file dati in entrata, e il criterio di separazione, vedrete i campi avvalorarsi e dovrete attribuire ad ogni campo il giusto significato in modo che AspToDba accodi correttamente i nuovi dati al database Access.

Una ad una aprite le tendine presenti sotto il valore scritto sui campi a fondo grigio (valori corrispondenti alla prima riga di dati del file Ascii) e attribuite il significato cliccando sul parametro presente nella tendina.

Nell'esempio, abbiamo attribuito al primo campo da sinistra il significato "Data. Così tutta la prima colonna di dati verrà letta come "Data"

Nota: quando su questi campi a fondo grigio (da 18 a 25) appaiono simboli non presenti nel file della finestra (17), come barre, punti ecc., significa spesso che c'è un errore nella scelta del separatore di campo. E' allora necessario, prima di procedere all'aggiornamento del database, modificare tale criterio, fino a far apparire valori coerenti.

Attribuzione significato ai campi

Attribuzione significato ai campi

Via, via completate l'attribuzione del significato dei campi per tutti i valori in essere.

Non ha importanza la sequenza dei campi del file Ascii. Ad esempio, non è necessario che la data sia il primo campo a sinistra, ciò che conta è che ad ogni colonna venga attribuito il corretto significato.

E' necessario che il file dati Ascii contenga in ogni colonna dati omogenei. Ad esempio, nella prima colonna sempre la data, nella seconda il codice titolo ecc.

Note

Subito sopra le tendine di attribuzione campo c’è il valore che verrà effettivamente importato per quel campo. AspToDba contiene delle protezioni per evitare che importiate valori errati nel vostro database. Ad esempio non vi fa scrivere il nome al posto della data, controllando la compatibilità del formato dei dati del file in entrata con quelli del file d'uscita.

E’ opportuno, soprattutto all’inizio, finché non avrete confidenza con il sistema, fare una copia di backup del vostro database, prima dell’aggiornamento.

Per proteggere i dati già presenti nel database, sui quali potreste anche essere intervenuti, ad esempio, con rettifiche di valore, AspToDba non scrive nulla, se la cella di destinazione non è vuota. Questo controllo è un passaggio in più e rallenta gli aggiornamenti.

Se volete velocizzare l'aggiornamento dati, evitando di controllare che le celle di destinazione siano vuote, potete inibire il controllo mettendo il flag nell'apposita casella: .

In questa situazione, se AspToDba trova dati da sovrascrivere si blocca, chiudendo l'applicazione con un

"Errore di Runtime 3022".

Cancellando il flag si ripristina il controllo ed il programma salta i dati già scritti e accoda gli altri.

Per la gestione / cancellazione dei dati vedere Rettifica

Se il file dati in entrata presenta nella prima riga la descrizione delle colonne, bisogna mettere il flag sul campo:

Una volta completato correttamente l'abbinamento tra campi e valori, si deve cercare il database da aggiornare, con il pulsante "percorso database".

E' tutto pronto. Il comando "Aggiorna Database" (7) accoda i dati presenti nel file Ascii al database Access.

Argomenti correlati:

Il database

Formato File dati

Come acquisire i dati da Internet

Rettifica


Accesso ai files dati (input e output)

Accesso al file dati (dati in entrata)

Bisogna assegnare ad AspToDba il file dati scaricato da Internet (file in entrata) che sarà usato per l'aggiornamento del database.

Con questa finestra di dialogo scegliamo il disco (3), la directory (1) ed il file (2), sempre con doppio click sull'elemento da selezionare.

Per semplificare la ricerca dei files, nel campo estensione (4) potete scrivere *.txt, o *.asc, o qualsiasi altra estensione, preceduta da asterisco e punto e, nella finestra superiore, (2) saranno visibili solamente i files con quell'estensione.

La directory "..RDLeA" è qui definita a puro titolo di esempio. Voi dovrete selezionare la stessa directory dove avete salvato i files scaricati da Internet.

Esempio di finestra per la selezione del file dati in entrata.

Definizione del Database (dati in uscita)

Cliccando sul pulsante "Percorso Database" si apre questa finestra che verrà utilizzata per definire il percorso del database (file dati in uscita) da aggiornare. La directory C:\Programmi\RealCharts" è qui definita a puro titolo di esempio e potrebbe essere diversa ("Rocco", "Andromeda", "RealChartsTS" ecc.) se vengono installati altri programmi.

Anche la funzione Rettifica lavora sullo stesso database selezionato da questa finestra.

Esempio di finestra per la selezione del database da aggiornare.

Una volta selezionato il file, cliccate su "Conferma Percorso".

NOTA: Con alcuni sistemi operativi, la prima volta che utilizzate AspToDba, questa finestra potrebbe rimanere nascosta sotto il pannello principale. Per farla apparire in primo piano è sufficente ridurre a icona o spostare il pannello principale stesso.

Argomenti correlati:

Abbinamento campi

Il Database

Rettifica

Formato files dati


Aggiornamenti manuali

Aggiornamenti manuali

E' possibile aggiornare manualmente i dati utilizzando l'apposita funzione che si apre cliccando sul pulsante "Aggiornamento manuale" (10) del pannello comandi. La funzione aggiornamento manuale NON consente l'inserimento di nuovi titoli, ma solo di prezzi per i titoli già presenti.

Aggiornamento manuale

Con il pulsante "#" si apre l'elenco titoli presenti nel database. Basta cliccare su un titolo per inserirlo sulla finestra qui a sinistra per il successivo aggiornamento dati.

Elenco titoli per aggiornamento manuale

Formato di inserimento dati.

Potete aggiornare i dati, purché le celle di destinazione siano vuote. Se non lo sono, prima di scrivere dovrete procedere con la cancellazione dei dati presenti. (Funzione "rettifica" dei programmi di charting e trading system)

(Le date vanno scritte nel formato GG/MM/AA, oppure GG/MM/AAAA.

Separatore decimale dei prezzi è lo stesso impostato nel vostro PC, da pannello di controllo > impostazioni internazionali > numeri > separatore decimale: virgola, o punto.
In Italia di solito si usa la virgola

Importante completare TUTTI I CAMPI. Se non conoscete il volume scrivete zero.

La frase "aggiornamento non effettuato!" appare ogni volta che si tenta di sovrascrivere dati già presenti. Nel caso in cui vogliate sostituire dati già scritti, procedere prima alla cancellazione con la funzione "Rettifica".

Scritti i valori premete "Aggiorna". A questo punto si ripresenta la finestra pulita, salvo che per il Codice Pk ed il nome del titolo. Questo per agevolare l'inserimento di più giorni di dati per lo stesso titolo.

Un altro modo per aggiornare manualmente i dati è quelli di predisporre dei files testo, usando il blocco notes di Windows (*.txt) ed elaborarli poi con AspToDba come quelli scaricati da Internet. Il formato deve essere quello previsto. In questo modo è anche possibile anche creare nuovi titoli.

Argomenti correlati:

Formato files dati in ingresso

Rettifica/cancellazione dati e creazione nuovi titoli


Il database

Il database.

Qualsiasi grafico è un'elaborazione che parte dai dati contenuti in uno o più files, comunemente definiti database. Senza questi dati il programma non funziona. Ma anche usando dati non corretti, ossia pieni di buchi, non aggiornati, non rettificati, in una parola inaffidabili, qualsiasi software non potrà fornire grafici attendibili.
Il database è formato da quattro prezzi per ogni giorno: apertura, massimo, minimo e chiusura ed, eventualmente i volumi.

Il nostro database, è compatibile con tutto il nostro software che usa dati. Quindi compatibilità assoluta, ma nello stesso tempo, ogni programma lavora sul database in modo autonomo. Ad esempio, l'ottimizzazione di Andromeda non è visibile da Rocco e viceversa, così come ogni programma crea le sue liste titoli esclusive all'interno del database. Il grande vantaggio che ne consegue è che l'aggiornamento dati, anche se si usano più programmi, si fa una volta sola
Questi files, "mdb", consentono di gestire grandi quantità di informazioni. Inoltre il formato Access ed il relativo programma, sono molto diffusi e consentono a chiunque, di gestire ed eventualmente manipolare i dati a piacere.
Naturalmente il nostro software può essere utilizzato anche senza disporre di Access, in quanto ogni programma è fornito degli strumenti per la gestione dei titoli, quale aggiornamento manuale, rettifica e cancellazione dei dati.
I programmi vengono consegnati corredati di un database matrice, "Master.mdb" vuoto che, duplicato e rinominato, (si possono utilizzare le funzioni copia, incolla e rinomina da gestione risorse di Windows) potrà contenere i dati di altri mercati, ad esempio Nasdaq. mdb, Germany.mdb ecc. E' consigliabile infatti, se si studiano più mercati, usare files di dati diversi per ogni mercato.

Dal sito www.borsatech.com, che ha cortesemente pubblicato database compatibili con i nostri programmi, potete scaricare gratuitamente (basta registrarsi con cognome, nome ed e_mail):

FondiBt.mdb : che contiene lo storico dati di circa 1000 Fondi Comuni Italiani dal 1999.

I taliaBt.mdb: che contiene lo storico dati di Borsa Italia e Indici italiani ed internazionali dal 1994.

Istruzioni per l'uso:
Scaricare i files, dezipparli e copiarli nella stessa directory di installazione dei programmi.

Nota: l'aggiornamento dei dati consiste nell'accodamento di nuovi dati a quelli già presenti.

L'ordine cronologico dei dati che vengono aggiunti, tuttavia, non ha alcuna importanza, in quanto la corretta cronologia viene gestita in automatico dai programmi principali come Rocco, RealChartsTS ecc.

E' così possibile accodare in qualunque momento e senza problemi dati storici meno recenti ad un database contenente dati aggiornati, così come inserire titoli con i relativi dati storici.

Il database contiene dati "daily": per ogni giorno di trattazione Apertura, Massimo, Minimo e Chiusura ed è composto da due tabelle una che gestisce l'anagrafe dei titoli ed una per i dati.

L'anagrafe contiene il nome di tutti i titoli, ciascuno corredato dal suo codice univoco di riconoscimento e una serie di dati di servizio come la data dell'ultima rettifica dati, l'ultimo fattore di rettifica, i parametri salvati dalle ottimizzazioni dei trading systems, indirizzi di files di sistema ecc.

La tabella dati contiene per ciascuna riga dati un codice di collegamento con la tabella nomi, la data, i quattro dati giornalieri ed i volumi.

Argomenti correlati

Accesso al database

Gestione database (funzione rettifica)


Formato files dati in entrata

Formato Files Dati.

I files formato testo (files in entrata) dovranno contenere otto campi per ogni titolo:

  1. Data; (formato data)

  2. Codice titolo (formato alfanumerico)

  3. Nome Titolo (formato alfanumerico)

  4. Apertura (formato numerico)

  5. Massimo (formato numerico)

  6. Minimo (formato numerico)

  7. Chiusura (formato numerico)

  8. Volume (formato numerico)

Il numero di campi per i valori numerici è libero.

Separatore decimale è il punto.

I campi sono tutti obbligatori. Se non disponete di apertura, massimo e minimo, potete inserirli uguali al valore di chiusura, per evitare di inserire zero che sporcherebbe i grafici a candele e barre.

Il Volume invece può essere lasciato a zero.

L'ordine dei campi non è obbligato, dato che con AspToDba è possibile, con l'abbinamento campi, attribuire ad ogni campo il giusto significato.

Una volta salvato il file con estensione txt, va dato da lavorare ad AspToDba come i normali files scaricati da Internet.

Separatore di campo tabulazione, ";" o spazio.

Esempio di file compatibile con:

separatore di campo = tabulazione;

separatore decimale = punto;

formato data = MM/GG/AAAA;

campo "Volumi" = zero.

"""""""""""""""

Date Cod Name Open Max Min Close Vol.

02/03/2003 IXIC NASDAQ Composite Index 1323.0800 1335.7600 1318.0200 1323.7900 0
02/03/2003 NDX NASDAQ 100 Index 984.9800 997.5600 981.6800 987.0700 0
02/03/2003 DJI Dow Jones Industrial 30 Index 8053.7000 8152.0000 8053.7000 8109.8000 0
02/03/2003 SP500 S&P 500 Index 855.7000 864.6400 855.7000 860.3200 0
02/03/2003 NYA NYSE Composite Index 4868.6800 4903.2800 4868.6800 4884.7900 0
ecc. ecc.

Nella directory di installazione del programma principale è presente un file "Esempio.asc" che è un file tipico di scarico dati da Internet.

Argomenti correlati:

Accesso ai dati

Scarico dati da Internet


Presentazione

Presentazione

Tutti i nostri programmi, sia trading systems che analisi tecnica, si appoggiano su una base dati comune scritta in Access. Lo stesso database serve quindi indistintamente per tutto il software RDL & A. Viene così semplificato il lavoro di aggiornamento, dato che si possono utilizzare programmi con funzioni diverse, eseguendo un solo aggiornamento dei dati.

Il database contiene dati "daily": per ogni giorno di trattazione Apertura, Massimo, Minimo e Chiusura ed è composto da due tabelle una che gestisce l'anagrafe dei titoli ed una per i dati.

L'anagrafe contiene il nome di tutti i titoli, ciascuno corredato dal suo codice univoco di riconoscimento e una serie di dati di servizio come la data dell'ultima rettifica dati, l'ultimo fattore di rettifica, i parametri salvati dalle ottimizzazioni dei trading systems, indirizzi di files di sistema ecc.

La tabella dati contiene per ciascuna riga dati un codice di collegamento con la tabella nomi, la data, i quattro dati giornalieri ed i volumi.

Il database fornito in dotazione, Master.mdb, può essere clonato con nomi diversi (con copia e incolla di WIndows) per ottenere un database per ogni mercato. (ad esempio Italy.mdb, Nyse.mdb, France.mdb, ecc.)

AspToDba è stato concepito per automatizzare le operazioni di aggiornamento dati utilizzando files formato testo scaricabili da Internet.

AspToDba ha quindi bisogno di un file in entrata, i dati scaricati da Internet, che vengono letti nel loro formato testo, e un file in uscita, il Database, nel quale i dati vengono accodati automaticamente a quelli già presenti.

Nessun problema se il database è vuoto. AspToDba scrive prima i nomi dei titoli, nella tabella nomi e quindi i relativi dati nella tabella dati. Così la gestione delle anagrafiche titoli è del tutto automatica.

Pannello di controllo

 Finestra inziale di AspToDba

All'apertura del programma appare il pannello di controllo:

  1. Finestra: selezione directory dove si trova il File dati scaricati da Internet (files in entrata)
  2. Finestra: scelta dei files presenti nella directory selezionata nella finestra 1 (files in entrata)
  3. Finestra: selezione disco dove si trovano i files in entrata
  4. Campo: filtro per la selezione del tipo files visibili in nella finestra 2 (file in entrata)
  5. Opzioni: selezione criteri di separazione delle colonne del file dati in entrata
  6. Opzioni: selezione del formato data (files in entrata)
  7. Pulsante per far partire l'aggiornamento del database
  8. Pulsante per interrompere l'aggiornamento del database
  9. Pulsante per aprire finestra che permette di scegliere il database da aggiornare (files in uscita)
  10. Pulsante per aprire la finestra di aggiornamento manuale del database
  11. Pulsante rettifica. Apre la finestra che permette la gestione dei dati presenti nel database
  12. Pulsante Help per aprire la guida
  13. Finestra per controllo record saltati (in uscita)
  14. Finestra per controllo record aggiornati (in uscita)
  15. Flag: quando selezionato salta la prima riga dati del file in entrata (potrebbe contenere l'etichetta delle colonne)
  16. Flag: quando selezionato non controlla se il record di destinazione è vuoto.
  17. Finestra per visualizzazione delle prime righe del file dati in entrata selezionato nella finestra (2).
  18. Campi da (18) a (25) campi per attribuzione significato a colonne dati (abbinamento campi files in entrata con database in uscita)

Argomenti correlati:

Accesso ai files dati

Aggiornamenti manuali

Database

Scarico dati da Internet


Rettifica Dati

Rettifica Dati.

Con il pulsante "Rettifica" si accede alla finestra che consente di correggere i prezzi di un titolo fino ad una certa data in conseguenza di assegnazioni gratuite (split), aumenti di capitale, raggruppamenti ecc. Il grafico che ne deriva è così "coerente" con i veri movimenti di borsa del titolo e non con i meri prezzi espressi dal mercato.

La funzione Rettifica lavora sullo stesso database selezionato per l'aggiornamento dei dati. Sulla riga in basso della finestra Rettifica viene evidenziato il percorso ed il database sul quale si sta intervenendo.

Finestra di rettifica e cancellazione dati

Descrizione della finestra "Rettifica":

  • Nome del titolo da rettificare; digitando le prime lettere, o tutto il nome del titolo che vi interessa, nel campo "Nome del Titolo" e aprendo la tendina con il mouse, oppure schiacciando il tasto freccia in giù sulla tastiera del PC, AspToDba si posiziona direttamente sul titolo scelto e si appropria del titolo e dei relativi dati presenti nel database. Quando nel campo appare il nome del titolo scelto, tutto è pronto.

  • l’intervallo di dati su cui interviene la rettifica o la cancellazione dati, con espressione delle due date, iniziale e finale. Tali date sono entrambe comprese.

  • il fattore di rettifica (che usa il punto quale separatore decimale) è il valore per il quale, nel periodo selezionato, vengono moltiplicati tutti i prezzi e divisi i volumi.

  • Il pulsante "Rettifica Dati" fa partire l'operazione di rettifica.

  • Al termine della rettifica AspTpDba ne salva le impostazioni nel database e le richiama in questa finestra, per possibili consultazioni. (Ultimo fattore AIAF e date di applicazione).

  • Il comando "Cancella i dati del TITOLO selezionato per il periodo indicato" permette di cancellare un certo periodo di dati da un singolo titolo. Cancellando TUTTI i dati di un titolo se ne elimina anche il nome dal database. Il periodo viene definito nei campi "Data Iniziale" e "Data Finale", entrambe comprese.

  • Il comando "Cancella i dati del periodo selezionato per TUTTI i TITOLI del database" permette di cancellare i dati di tutti i titoli su un determinato periodo, definito nei campi "Data Iniziale" e "Data Finale", entrambe comprese.

  • Crea Nuovo Titolo: per la creazione di nuove anagrafiche. Vanno inseriti: PK titolo che è il codice univoco del titolo e Nome Titolo. Entrambi i campi sono alfanumerici e non devono avere duplicati nella tabella "NOMI" del database.

  • La Funzione "Unione Dati" consente di accodare i dati di un titoli ad un altro. Si devono selezionare i due titoli interessati all'unione. Nella lista "Titolo di Partenza" il titolo da cui vengono prelevati i dati; nella lista "Titolo di Arrivo" il titolo ricevente. Tutti i dati del titolo di partenza vengono aggiunti a quello di arrivo, purchè sulle stesse date il titolo di arrivo non contenga altri dati. La funzione infatti fa un controllo sulle date e scrive solo dove trova spazi vuoti. Nulla viene cancellato o sovrascritto, sia dal titolo di partenza che di arrivo.

Nell'unione dati può accadere che i dati di partenza non siano coerenti con quelli di arrivo in quanto, ad esempio, in ogni titolo nuovo sono confluite 3 azioni vecchie. In questo caso, dopo l'unione, procedete con una normale rettifica dati (nell'esempio a 3,33333 dalla data iniziale fino all'ultima data del vecchio titolo).

Esempio di rettifica:

Ad esempio Fiat.mi valeva, prima del raggruppamento del 20 agosto 99, circa 3,2 €. Il lunedì successivo Fiat valeva 32 €, cioè 10 volte più del giorno prima, ma in realtà nulla era cambiato nel valore "vero" del titolo: solo furono sostituite 10 vecchie azioni con una sola di nuova. In questo caso il fattore di rettifica era 10, dalla data iniziale, fino al 20/08/99.
Al termine appare la nota "Rettifica effettuata" e vengono puliti i campi impostati per la rettifica, per evitare che, per errore, si intervenga con una doppia rettifica dei dati.

N.B.: può essere opportuno, prima di intervenire con rettifiche o cancellazione dati, fare una copia del database originale, e conservarla per ripristinare dati involontariamente danneggiati da manovre errate.

I fattori di rettifica sono disponibili su Internet al sito: http://www.aiaf.it/.

Argomenti correlati

Il Database

Accesso al database

Aggiornamento manuale


Come scaricare i dati da Internet

Scaricare i dati da Internet

Il modo più semplice per acquisire i files dati per aggiornare il database è quello di scaricarli da Internet, sottoscrivendo un abbonamento, ad esempio dal sito www.borsatech.com.

Per sottoscrivere l'abbonamento bisogna seguire le indicazioni pubblicate nei siti. Secondo il servizio sottoscritto, i dati arrivano via e_mail o possono essere prelevati dal sito che fornisce il servizio.

L'aggiornamento del database può essere fatto con la frequenza che si desidera, (giornaliera, settimanale o quando si ha tempo) e garantisce che non si perdano comunque dati. Una volta collegati al sito è sufficiente scaricare il file dati del giorno o del periodo che vi manca, e poi AspToDba, leggendo questo file, aggiorna il database automaticamente.

I dati vengono scaricati nel vostro PC, in un file che, al momento dello scarico, potete nominare e salvare come e dove preferite, con il consueto sistema di scarico dati da Internet.

Grazie al sito www.borsatech.com che ha cortesemente pubblicato database compatibili con i nostri programmi, potete scaricare gratuitamente (basta registrarsi con cognome, nome ed e_mail):

FondiBt.mdb : che contiene lo storico dati di circa 1000 Fondi Comuni Italiani dal 1999.

I taliaBt.mdb: che contiene lo storico dati di Borsa Italia e Indici italiani ed internazionali dal 1994.

Istruzioni per l'uso:
Scaricate i files, dezippateli e copiateli nella stessa directory di installazione dei programmi. Sono già pronti per l'uso.

Nota: Se usate altri fornitori di dati fate attenzione che i files siano nel formato compatibile.

Argomenti correlati:

Formato files dati

Accesso ai files dati.