SEX_SIM

INDICE ARGOMENTI

Che cos'è | Come funziona
Sex_Sim al lavoro | Infine ...

Che cos'è
SEX_SIM è un simulatore di trading. Consente di "allenarsi", senza conseguenze economiche (negative) a fare trading. Potrete provare a lavorare sul vostro sentiment, su supporti e resistenze immaginari, oppure sugli indicatori presenti. In ogni caso è avvincente simulare acquisti e vendite con prezzi che non potrete controllare (come in Borsa) e che si muovono in modo casuale, ma con una dinamica straordinariamente simile alla realtà. In pochi minuti potrete simulare anche un anno di trading. Così, un po' alla volta, applicando le nozioni apprese dai miei libri, ed esercitandovi con SEX_SIM, saprete interpretare in modo quasi intuitivo i messaggi di un grafico e fare vostre le regole che sono alla base dell'analisi tecnica.

Questa versione di Sex_Sim, è stata arricchita di un nuovo indicatore, BOB che è una media bollinger. Le bande di Bollinger sono uno strumento di analisi molto interessante: il loro scopo è quello di fornire una misura attendibile del grado di "normalità" delle variazioni nell'andamento di una serie storica sul periodo preso in esame. Vengono costruite partendo da una media mobile esponenziale di N giorni alla quale viene sommato (banda superiore) e sottratto (banda inferiore) un valore pari alla deviazione standard, calcolata sul periodo P e moltiplicata per un fattore superiore a uno, definito dall'utente.
La deviazione standard è un indicatore statistico che misura la variabilità intrinseca di una serie storica: nel nostro caso si considera la deviazione standard della serie storica nei N giorni precedenti quello attuale, una sorta di deviazione standard mobile. In questo modo le bande di Bollinger seguono l'andamento del titolo allargandosi o restringendosi a seconda della variabilità riscontrata nel periodo. La perforazione di una delle bande da parte del grafico del prezzo può allora indicare un movimento anomalo, in quanto eccede la variabilità storicamente "normale".
Oltre a Bob potete vedere l'R.S.I., (Relative Strenght Index). Questo indicatore, o Indice di Forza Relativa, consente di analizzare le situazioni di mercato, separando le fasi di normalità da quelle in cui è presente una eccessiva pressione della domanda (ipercomprato) oppure dell'offerta (ipervenduto).
In alternativa all'R.S.I. potete scegliere la visualizzazione dell'oscillatore Stocastico che si rivela utile per prevedere e anticipare le fasi di inversione di tendenza. E' composto da più elementi che potete impostare liberamente.

Come funziona

iniziale67.gif (16355 bytes)
Esempio di finestra iniziale di SEX_SIM per l'inserimento dei parametri di lavoro

Appena lanciato, SEX_SIM apre questa finestra. Vengono proposti parametri standard, che possono essere accettati così come sono, cliccando "Inizio simulazione" o personalizzati sovrascrivendo i dati presenti nei campi a fondo bianco, o cliccando sulle freccette a destra del campo per quelli a fondo grigio.

  • "Capitale iniziale in Euro" capitale massimo disponibile per l'investimento, espresso in Euro.
  • "Valore Beta" Il valore Beta indica la volatilità di un titolo rispetto al proprio mercato di riferimento. Un titolo con valore beta = 0,50 oscilla circa la metà rispetto all'indice del proprio mercato; se = 2,00 oscilla il doppio. Con questa variabile attribuiamo un valore Beta al nostro titolo virtuale.
  • "Margine di garanzia" In taluni mercati è possibile operare allo scoperto (vendere titoli che non si hanno) ma può essere richiesta una garanzia pari ad un valore percentuale dei titoli che si intendono vendere. Se qui viene indicato zero non potete operare allo scoperto, se 50% per un controvalore pari alla metà rispetto al capitale iniziale, se 100% uguale al capitale iniziale.
  • "Commissioni pagate alla Banca" Indicate la commissione percentuale trattenuta dalla Banca negoziatrice su ogni operazione.
  • "Variazione massima consentita su prezzo di riferimento giorno precedente" Quando il prezzo di un titolo si scosta molto rispetto al prezzo di riferimento del giorno precedente, viene sospeso automaticamente dal sistema informatico del Ced Borsa. Per rendere i prezzi generati da SEX_SIM coerenti con la realtà del mercato è opportuno impostare il valore al 10%.
  • "Giorni Media Mobile" Numero di giorni sui quali è calcolata la media mobile visibile sul grafico.
  • "Giorni RSI" indica il numero di prezzi (giorni) utilizzato dal programma per calcolare l'oscillatore R.S.I.
  • "Giorni Stocastico" indica il numero di prezzi (giorni) analizzati dal programma per generare lo stocastico;
  • "Giorni Linea K Stocastico" indica il numero di giorni della Media Mobile breve presente nello Stocastico (blu)
  • "Giorni Linea D Stocastico" indica il numero di giorni della Media Mobile lunga presente nello Stocastico (bianca)

Parametri BOB

  • Giorni media mobile: numero di giorni sui quali è calcolata la media mobile utilizzata per la defizione di BOB;
  • Deviazione standard: giorni utilizzati per il calcolo della deviazione standard;
  • N. dev. standard: moltiplicatore del valore della deviazione standard, utilizzato da BOB per la costruzione dell'ampiezza del canale.

Una volta che i parametri sono a posto, siete pronti per partire.
Cliccate sul pulsante "inizio simulazione" e … buon lavoro!

Sex_Sim al lavoro.

image19.gif (19733 bytes)
Esempio di finestra di lavoro di SEX_SIM

SEX_SIM genera casualmente, sulla base del Beta del titolo e dell'oscillazione massima giornaliera impostate nella maschera precedente, una serie storica di 300 prezzi che è possibile visualizzare nella finestrella in alto a destra, sotto "data" - "prezzo" - "Tipo Operazione". Facendo scorrere il cursore, o con freccette a destra della finestrella, i dati scorrono fino al primo prezzo generato. Cliccando su una data presente nella finestra il grafico limita la visualizzazione dalla data evidenziata ad oggi (effetto zoom). Per ritornare allo storico completo, cliccare sulla data più vecchia della serie, che si vede dopo aver fatto scorrere fino in fondo il cursore.

Subito sotto è visibile la data odierna con il prezzo generato per oggi.

Sulla destra i pulsanti:

  • "Help" mostra la descrizione dei comandi e del programma ed e_mail per ulteriori informazioni;
  • "Rendiconto" mostra in qualunque momento il riepilogo analitico dei movimenti;
  • "Riparti" riparte dalla videata iniziale;
  • "Uscita": uscite da SEX_SIM.

Selezionate "R.S.I.", o in alternativa "Stocastico" per visualizzare, con i parametri che avete impostato, un indicatore o l'altro sotto il grafico.

Selezionate "BOB" per vedere il canale generato dai parametri impostati.

"Griglia sul grafico", se vi piace, o meno,

"Scorrimento" il grafico scorre mostrando sempre 300 prezzi a partire dall’ultimo (opzione consigliata), oppure tutta la serie.

SEX_SIM mostra inoltre, in tempo reale, quanti soldi avete ancora a disposizione (in Euro) nel campo "Capitale", qual è il "Costo di carico" medio ed il "Totale azioni" in portafoglio o, se con segno negativo, vendute allo scoperto.

Con i tre pulsanti in alto a destra:

  • "Acquista": decidete di comprare al prezzo di oggi il numero di azioni indicato nella finestra a fianco. Il numero proposto per default può essere modificato a piacere (entro il limite del capitale disponibile). SEX_SIM posiziona un pallino rosso sotto il grafico in corrispondenza del giorno in cui avete acquistato.
  • "Vendi": vendete, con gli stessi criteri sopra descritti, salvo il pallino che è blu e viene posto sopra il grafico.
  • "Passa": per oggi non fate nulla. SEX_SIM genera un nuovo prezzo che accoda alla serie storica ed il grafico si aggiorna immediatamente. Prima di cliccare nuovamente su "passa" è consigliabile aspettare che il PC abbia elaborato la richiesta precedente.

N.B.: ad ogni click su uno di questi tre pulsanti SEX_SIM aggiunge un prezzo (che nel grafico corrisponde ad un giorno) alla serie storica, . Non è possibile nella stessa giornata fare più di una operazione. Il numero di azioni che si compra-vende può essere modificato a piacere ogni giorno, ma il prezzo non può essere modificato e viene assegnato da SEX_SIM. Infine, una volta cliccato su "Passa", non si può tornare indietro.

Ora potete finalmente vedere il risultato della vostra prova. SEX_SIM, per mezzo del pulsante "Rendiconto" apre una finestra che illustra analiticamente il vostro operato. Avete guadagnato o perso? Potete anche chiudere il rendiconto e continuare.

SEX_SIM, nel rendiconto, vi mostra utile/perdita di ogni operazione chiusa ed il riepilogo finale. Se uscendo dal programma vi dimenticate qualche operazione aperta non c'è problema: SEX_SIM ve la chiude automaticamente al prezzo del giorno e la riporta nel rendiconto che vi apre, sempre automaticamente, subito dopo.

I rendimenti, assoluto e percentuale, vengono calcolati sul capitale massimo disponibile, per cui è opportuno, per ottenere buoni risultati, impiegare il massimo possibile del capitale, o, se preferite, regolare il capitale iniziale in funzione di quello che volete fare. Se, ad esempio, otterrete risultati eccellenti (+75%), ma avrete investito solo il 10% del capitale, il vostro risultato finale sarà appena del +7,5%. Viceversa un +20% sul 90% del capitale fa + 18% finale.

Infine ...
Il trading è uno "sport" che richiede conoscenze tecniche e raramente perdona gli errori. Un po' come la montagna. Chi mai si avventura a scalare una vetta impegnativa senza adeguata preparazione? Gli scalatori hanno le loro palestre di roccia. Ora, con SEX_SIM, gli aspiranti trader hanno la loro "palestra di mercato".

In bocca al lupo!