sexsim

SexSimPro

Che cos'è

Le caratteristiche

Come funziona

Menù comandi

Pannello di controllo

Console di comando

Il giudizio

Infine ricordate...

Che cos'è

Chiusa l'ultima pagina del libro di analisi tecnica la sensazione di aver compreso tutto ci pervade. Finalmente abbiamo scoperto molti dei segreti della finanza e siamo quasi convinti che stavolta ce la potremo fare. Quasi convinti...

Eppure abbiamo capito le regole del gioco. Cosa ci vuole ancora?

Forse solo la sicurezza delle nostre convinzioni, sicurezza che nasce dall'esperienza. Allora è vero: dopo la teoria serve la pratica. Ma com'è possibile accumulare esperienza senza mettere a rischio la nostra tranquillità finanziaria, il nostro capitale?

C'è un solo modo. Provare su un simulatore di trading.

I piloti usano molto i simulatori di volo, strumenti sofisticatissimi che costano anche più di un aereo vero e proprio. Replicano i comandi della cabina dell'aereo e simulano il volo vero e proprio. Per il pilota l'unica differenza tra l'aereo e il simulatore è che l'errore non si paga. Sbagliando s'impara e l'errore insegna a volare, ma non costa l'integrità dell'aereo, né vite umane.

Allo stesso modo SexSimPro insegna a fare trading senza che sia necessario mettere capitale a rischio.

SexSimPro: finalmente il simulatore di trading evoluto che vi esercita nel trading aiutandovi con gli strumenti di un programma di analisi tecnica. SexSimPro lavora anche su titoli veri ricostruendone giorno per giorno la storia senza svelarvi il nome, se non alla fine dell'esercizio. Vi troverete così a dover scegliere la vostra posizione su quel titolo ogni giorno. Cosa facci oggi: vendo, compro, aspetto.... E ogni giorno così, come accade nella realtà, con un grande vantaggio però: non dovete aspettare mesi o anni per sapere come va a finire; in pochi minuti potete simulare molti giorni, mesi, addirittura anni.

Al termine di ogni simulazione SexSimPro, da un bravo "tutor", vi fornisce il rendiconto delle vostre operazioni (come la banca) ed esprime un giudizio sui risultati. Capirete presto l'importanza di applicare gli stop loss, il rischio che si corre ad andare contro il mercato, quanto costa non "decidere". Insomma potrete finalmente mettere in pratica le regole a base dell'analisi tecnica, senza l'effetto "ingessatura" provocato spesso dai soldi veri.

Finestra di Lavoro di SexSimPro (dati da vera serie storica )

Le caratteristiche

SexSimPro è un software di charting che disegna grafici a zig-zag, barre o candele giapponesi, e assume i dati in due modi alternativi a vostra scelta:

1 . generando lui stesso i prezzi (apertura, massimo, minimo e chiusura)

2 . leggendo i dati storici di un titolo a caso fra quelli contenuti in un database.

Una volta aperto il grafico sta a voi studiarlo ed interpretarlo e qui SexSimPro vi può aiutare parecchio con le sue funzioni di analisi tecnica. Dispone infatti di:

  • due medie mobili esponenziali;

  • medie bollinger

  • Media Kaf

  • Media centrata

  • volumi

  • RSI

  • Deviazione standard

  • pista ciclica

  • stocastico

  • media mobile sugli oscillatori

  • possibilità di disegnare, spostare e copiare sul grafico rette di supporto e resistenza in cinque colori

  • ventaglio di Gann con reverse

  • personalizzazione della finestra del grafico con griglie e ordinata destra

  • grafico a zig-zag, barre o candele giapponesi

Oltre alla funzione rendiconto, con evidenza analitica di tutte le operazioni poste in essere e, al termine, il risultato sintetico dell'esercizio appena chiuso.

Potrete lavorare su supporti e resistenze da voi disegnati, sugli oscillatori disponibili, o sulle medie mobili a disposizione. In ogni caso è avvincente acquistare e vendere come da un trading on line. Così, un po' alla volta, applicando le nozioni imparate sui libri, ed esercitandovi con SexSimPro, saprete interpretare in modo quasi intuitivo i messaggi di un grafico facendo vostre le regole che sono alla base dell'analisi tecnica. Potrete provare, in modo particolare, ad applicare lo stop loss, cosa che spesso, con soldi veri, si rivela più facile a dirsi che a farsi, soprattutto quando non si è abbastanza "allenati".

Finestra di Lavoro di SexSimPro (dati simulati)

Come funziona

Appena lanciato, SexSimPro appare come una finestra vuota.

Vediamo le opzioni presenti a menù:
Da menù File, in alto a sinistra, per iniziare è possibile:

  • Aprire una nuova simulazione (F2) con dati generati direttamente dal programma. In questo caso non è richiesto il database.
  • Aprire una nuova simulazione (F3) con dati veri. In tal caso si dovrà assegnare a SexSimPro un database.
  • Assegnare il database dal quale SexSimPro potrà scegliere i titoli per gli esercizi;

Nel caso scegliate che i prezzi siano generati direttamente da programma, si apre questa finestra nella quale potete definire i tre campi presenti:
  • Numero di dati simulati da generare: decidete quanto lunga dovrà essere la serie storica da generare. In questo esempio vengono generati i dati completi (apertura, massimo, minimo e chiusura) di 5.000 giornate, cioè circa 20 anni di borsa aperta. Si crea così la base dati del titolo sul quale lavorerete.
  • La data di partenza simulazione corrisponde alla data iniziale della serie storica generata.
  • Numero dati da visualizzare: espone graficamente il primo segmento (in questo caso 200 giorni) di dati generati, facendo partire l'operatività dall'ultimo giorno di tale segmento.

Finestra per impostare la generazione di dati

Nel caso si vogliate utilizzare "dati veri" si dovrà indicare a SexSimPro l'indirizzo del database cui appoggiarsi, da questa finestra del tipo "gestione risorse". Selezionate il file del tipo "mdb" e cliccate su "Conferma percorso".

Questa operazione si deve fare solo la prima volta che si usa il programma per individuare un database. Nelle successive sessioni SexSimPro ricorderà l'indirizzo assegnato la prima volta.

SexSimPro viene fornito completo di un database contente le serie storiche di circa duecento titoli italiani.

Da menù Opzioni:

  • Fido c/c: cliccandolo si attiva la possibilità di acquistare senza limiti di importo oltre la liquidità impostata da pannello di controllo;

  • Vendita scoperto: cliccandolo si attiva la possibilità di andare "short", ossia di vendere anche i titoli senza possederli;

  • Scorrimento: il grafico scorre mostrando sempre N. prezzi a partire dall’ultimo (opzione consigliata), oppure tutta la serie, se disattivato.

Da menù Finestra è possibile inserire/togliere l'ordinata destra sul grafico;

Cliccando su "Rendiconto" appare l'estratto completo delle operazioni effettuate.

Menù comandi

Cliccando con il pulsante destro del mouse sull'area del grafico si accede al menù comandi contenuto in questa toolbar mobile che consente di:

Finestra Menù Comandi

  • Add TrendLine aggiunge rette al grafico. Una volta selezionato il comando da per tracciare la retta portarsi con il mouse sul grafico e, tenendo premuto il pulsante sinistro del mouse, creare la retta . Al rilascio del pulsante la retta si fissa.

  • TrendLine Orizzontale aggiunge rette orizzontali al grafico. Come sopra, salvo che la retta è orizzontale.

  • Copy TrendLine serve per tracciare i canali di trend. Selezionato il comando, cliccate sulla retta che volete copiare e trascinate. Viene generata un'altra retta identica alla prima che, al rilascio del pulsante del mouse, si fissa dove volete;

  • Modify TrendLine: una volta selezionato permette di variare l'inclinazione delle rette già tracciate, o di allungarle ed accorciarle.

  • Move TrendLine: consente di spostare qualsiasi retta;

  • Cancel TrendLine: dopo averlo selezionato cliccate su qualsiasi punto della retta che volete eliminare

  • Cursore Freccia: il puntatore del mouse viene visualizzato come una freccia;

  • Cursore Righello: il puntatore del mouse viene visualizzato come un incrocio tra due rette, una orizzontale ed una verticale. Aiuta a valutare meglio gli oscillatori in rapporto al grafico dei prezzi;

  • Attiva Zoom: dopo aver attivato la funzione selezionate sul grafico l'area che volete ingrandire, trascinando il mouse da sinistra a destra con il pulsante sinistro schiacciato.

  • Ripristina Zoom: per tornare alla situazione precedente la zoomata

  • Right TrendLine: allunga a destra la retta selezionata

  • Left TrendLine: allunga a sinistra la retta selezionata

  • Allunga_Tutte: allunga a destra tutte le rette presenti sul grafico

  • GannLines: disegna il ventaglio di Gann. Per ottenere un buon risultato, si deve prima identificare un trend. Se è al rialzo si unisce con il mouse il punto minimo con il massimo. Il ventaglio che ne deriva ipotizza i possibili ritracciamenti di 1/3, 1/2, 2/3. . Viceversa se lavorate su un trend al ribasso.

  • Inverso_Gann: può essere attivato solo dopo aver disegnato le GannLines: disegna un altro ventaglio che, parte dal massimo, ha la stessa angolatura di quello precedente, ma è inclinato in senso opposto

  • Colori: scegliete il colore che preferite per le vostre rette, selezionandolo prima di tracciarle.

Vediamo le funzioni del pannello di controllo:

Pannello Comandi

  • data iniziale: facendo scorrere questo cursore potete allargare il periodo visualizzato nel grafico dal lato della data iniziale, fino al primo dato contenuto nel database, o generato dal sistema; lo stesso risultato si può ottenere anche aprendo la tendina della data e selezionando la data iniziale per il grafico. Nel caso in cui tale data vada oltre il primo giorno di dati disponibile, il grafico verrà visualizzato dal primo dato disponibile.
  • data finale: questo cursore vi permette di ridurre il periodo visualizzato nel grafico restringendolo sul lato destro.
  • Commissioni: Indicate la commissione permille trattenuta dalla Banca negoziatrice su ogni operazione.
  • Liquidità: scegliete il vostro capitale da investire, in Euro, prima di iniziare.
  • Media Exp: (due disponibili) per disegnare sul grafico una media mobile esponenziale attivare il flag e indicare il numero di giorni sui quali viene calcolata.
  • BOB: è una media bollinger. Le bande di Bollinger sono uno strumento di analisi molto interessante: il loro scopo è quello di fornire una misura attendibile del grado di "normalità" delle variazioni nell'andamento di una serie storica sul periodo preso in esame. Vengono costruite partendo da una media mobile esponenziale di N giorni (primo parametro a sinistra) alla quale viene sommato (banda superiore) e sottratto (banda inferiore) un valore pari alla deviazione standard, calcolata sul periodo P (parametro centrale) e moltiplicata per un fattore superiore a uno, definito dall'utente (parametro a destra)
  • Media Kaf: si tratta di una media mobile adattativa, che si adatta cioè, allungandosi ed accorciandosi, alla serie storica dei prezzi in base alla velocità di variazione dei prezzi stessi. Quanto più il momentum è lontano da zero, tanto più la media Kaf prende velocità, avvicinandosi al trend. I tre parametri utilizzati sono, da sinistra: 1 = giorni sui quali viene definito il momentum; 2 = giorni prima mobile esponenziale; 3 = giorni seconda media mobile esponenziale;
  • Media Centrata: E' una media esponenziale spostata indietro di N giorni e rettificata in base alla volatilità del titolo. Corregge il ritardo fisiologico di qualunque media mobile, rispetto al trend sul quale è calcolata. Con fattore di ponderazione della deviazione standard pari a zero si ottiene la centratura della media, che si abbassa, rispetto al trend, con fattore superiore. I tre indicatori utilizzati sono, da sinistra: 1 = giorni media mobile; 2 = giorni deviazione standard; 3 = fattore di ponderazione della deviazione standard.

Il pulsante "Aggiorna" fa leggere a SexSimPro i nuovi valori impostati per i suddetti parametri.

Fra i campi presenti su Indicatori/Oscillatori se ne può selezionare uno. Verrà visualizzato sulla parte inferiore della finestra del grafico:
  1. Volume: mostra i volumi sul titolo;
  2. RSI o Relative Strenght Index. Questo indicatore, o Indice di Forza Relativa, è anch'esso un misuratore di "momentum", perchè indica, in sostanza, quante volte negli ultimi n giorni il titolo ha subito più rialzi che ribassi. Consente quindi di analizzare in modo efficiente gli stati del mercato, individuando le fasi di normalità da quelle in cui è presente una maggior pressione della domanda (ipercomprato) oppure dell'offerta (ipervenduto). Il parametro liberamente impostabile indica gli n giorni.
  3. Deviazione standard: rappresenta una misura della volatilità dei prezzi in un determinato periodo, ossia quantifica il loro scostamento dalla media a n giorni. Il metodo di calcolo usato è quello dello scarto quadratico medio.
  4. Pista ciclica: L'esame degli scarti in un determinato periodo di tempo tra le quotazioni giornaliere e le medie mobili costituisce un valido elemento per interpretare l'andamento del corso di un titolo. Sul calcolo di questi scarti si basa l'indicatore Pista Ciclica. Il parametro liberamente impostabile indica gli n giorni sui quali viene calcolata.
  5. Stocastico: Questo oscillatore si rivela utile per prevedere e anticipare le fasi di inversione di tendenza e indica chiaramente gli stati di ipercomprato e ipervenduto confrontando l'ultimo prezzo con i massimi ed i minimi toccati negli n giorni precedenti. Su tali valori viene poi disegnata una prima media mobile semplice, cosiddetta Fast o Veloce, sulla quale, a sua volta ne viene calcolata un'altra Slow o Lenta. I tre parametri utilizzati sono, da sinistra: 1 = giorni sui quali vengono cercati i massimi ed i minimi; 2 = giorni prima mobile semplice; 3 = giorni seconda media mobile semplice;
  • Media Exp: inserisce una media esponenziale a N giorni su uno degli indicatori/oscillatori visualizzati nella parte inferiore del grafico.

Il pulsante "Aggiorna" fa leggere a SexSimPro i nuovi valori impostati per i suddetti parametri.

Console di comando

Vediamo le funzioni della console di comando:

comprate al prezzo di chiusura di oggi il numero di azioni indicato nella finestra "Quantità" che potete modificare a piacere, entro il limite del capitale disponibile, se non avete fido, o, viceversa, anche oltre. SexSimPro posiziona una barra rossa alla base del grafico in corrispondenza del giorno in cui avete acquistato.
vendete, con gli stessi criteri sopra descritti, salvo che SexSimPro appone una barra blu alla base del grafico.
per oggi non fate nulla. SexSimPro genera una nuova giornata di prezzi che accoda alla serie storica, oppure legge nel database i dati del giorno successivo ed il grafico si aggiorna immediatamente.

Quantità: evidenzia la quantità di azioni che intendete negoziare;

Saldo: mostra il numero di azioni di cui disponete (saldo positivo o negativo)

Finestra movimenti: mostra l'ultimo movimento o, se aperta, tutti i movimenti che avete effettuato;

Eur: mostra, in tempo reale, il saldo disponibile sul vostro conto, aggiornato con i pagamenti/incassi derivanti dalle negoziazioni;

  • Cliccando [image] cambia il formato grafico in successione zig-zag, barre e candele giapponesi;
  • inserisce/toglie la griglia dal grafico.

Ora conoscete tutti i segreti di del vostro nuovo simulatore e potete iniziare.

In qualunque momento con pulsante "Rendiconto" SexSimPro apre una finestra che illustra analiticamente il vostro operato. Avete guadagnato o perso? Potete anche chiudere il rendiconto e continuare. SexSImPro nel rendiconto vi mostra utile/perdita di ogni operazione chiusa ed il riepilogo finale. Se uscendo dal programma vi dimenticate qualche operazione aperta non c'è problema: SexSimPro ve la chiude automaticamente al prezzo di chiusura del giorno in cui avete chiuso e la riporta nel rendiconto che vi apre, sempre automaticamente, subito dopo.

Il rendimento percentuale viene calcolato sul capitale iniziale.

Finestra rendiconto

Il giudizio

Finestra esempio 1 risultato

Alla chiusura, assieme al rendiconto viene aperta anche un'altra finestra che, nel caso in cui abbiate usato il database, svela il nome del titolo su cui avete lavorato, la performance percentuale ed un giudizio sull'esito dell'esercizio modulato su diversi livelli, in base al risultato.

Finestra esempio 2 risultato

Infine ricordate...

Il trading è uno "sport" che richiede conoscenze tecniche e raramente perdona gli errori. Un po' come la montagna. Chi mai si avventura a scalare una vetta impegnativa senza adeguata preparazione? Gli scalatori hanno le loro palestre di roccia. Ora finalmente con SexSimPro, gli aspiranti trader dispongono di uno strumento dalle caratteristiche professionali, una vera "palestra di mercato".

In bocca al lupo!