Indice

logo.gif (1624 bytes)

Rocco

Elenco argomenti trattati nella guida:

Presentazione

Il Database

Descrizione finestre e pannello comandi

Console

L'ottimizzazione

Il trading

La lista titoli

Il rendiconto grafico

Rettifica dati

Il Modulo Chart


Console d'impostazione parametri

Torna alla pagina iniziale

CONSOLE DI CONTROLLO

I parametri da impostare corrispondono al range di valori all'interno dei quali Rocco cerca le due medie ottimali, cliccate il pulsante "Console" Si apre questa finestra:

I parametri da ottimizzare sono due e corrispondono alla lunghezza delle due medie mobili. Per ciascuna media ci sono due cursori. Con il primo si imposta il valore minimo di ricerca, con l'altro il massimo. Il risultato sarà quindi compreso tra questi due valori. Spostate i cursori fino ai valori desiderati. Nell’esempio di questa figura Rocco proverà ad incrociare tutte le medie mobili comprese tra 2 e 10, (quindi 2, 3, 4, 5 fino a 10) con le medie mobili comprese tra 3 e 60.

Una volta impostati da "Console" i range verranno memorizzati per tutte le future ottimizzazioni, (Lista compresa), fino a vostra successiva modifica.

Il segnale di trade arriva quando la media più breve perfora al rialzo (acquisto su golden cross) o al ribasso (vendita su devil cross) quella più lunga.

Rocco mostrerà il risultato migliore in termini di rendimento, ma potete cambiare per vedere il maggior numero di operazioni in utile. Al prossimo accesso ritornerà la scelta di default (miglior rendimento).

Commissioni e vendite allo scoperto

Vendita allo scoperto e Commissioni

Consenti vendita allo scoperto: attivato = SI

Commissioni permille pagate all'intermediario su ogni operazione di acquisto o vendita, ai fini del rendiconto.

Le Date

Se il database contiene dati storici di diversi anni, potete escluderne una parte dall’ottimizzazione, sia perché i dati recenti sono i più significativi, sia per aumentare la velocità di elaborazione.

Spostando il cursore si modifica la data di inizio elaborazione.

Se invece volete considerare sempre gli ultimi 200 dati, (la data iniziale scorre in avanti giorno per giorno) impostate 200 nella casella GG analisi e poi OK.

Tali opzioni valgono per tutte le ottimizzazioni.

Le date

Argomenti correlati:

Ottimizzazione

Lista titoli

Trading


Il database

IL DATABASE

Rocco, come tutti i nostri programmi che usano dati, si appoggia su una base dati comune scritta in Access. Lo stesso database serve quindi indistintamente per tutto il software RDL & A. Viene così semplificato il lavoro di aggiornamento, dato che si possono utilizzare programmi con funzioni diverse, eseguendo un solo aggiornamento dei dati.

Alla partenza, Rocco cerca il database su cui lavorare. Se è stato chiuso correttamente ricorda ed utilizza l’ultimo sul quale avete operato. Se non lo trova vi apre una finestra, del tipo "gestione risorse" per consentirvi un’agevole ed intuitiva selezione del file che dovrà essere un database compatibile, come vedremo in seguito al punto "Il Database"

Una volta che avrete evidenziato il database che vi serve, cliccate su "Conferma percorso".

Il database contiene dati "daily": per ogni giorno di trattazione Apertura, Massimo, Minimo e Chiusura ed è composto da due tabelle una che gestisce l'anagrafe dei titoli ed una per i dati.

L'anagrafe contiene il nome di tutti i titoli, ciascuno corredato dal suo codice univoco di riconoscimento e una serie di dati di servizio come la data dell'ultima rettifica dati, l'ultimo fattore di rettifica, i parametri salvati dalle ottimizzazioni dei trading systems, indirizzi di files di sistema ecc.

La tabella dati contiene per ciascuna riga dati un codice di collegamento con la tabella nomi, la data, i quattro dati giornalieri ed i volumi.

Il database fornito in dotazione, Master.mdb, può essere clonato con nomi diversi (con copia e incolla di WIndows) per ottenere un database per ogni mercato. (ad esempio Italy.mdb, Nyse.mdb, France.mdb, ecc.)

AspToDba è stato concepito per automatizzare le operazioni di aggiornamento dati utilizzando files formato testo scaricabili da Internet.

AspToDba ha quindi bisogno di un file in entrata, i dati scaricati da Internet, che vengono letti nel loro formato testo, e aggiorna, in uscita, il Database, nel quale i nuovi dati vengono accodati a quelli già presenti.

Nessun problema se il database è vuoto. AspToDba scrive prima i nomi dei titoli, nella tabella nomi e quindi i relativi dati nella tabella dati. Così la gestione delle anagrafiche titoli è del tutto automatica.

Rimandiamo per ulteriori informazioni all'help di AspToDba.

Argomenti correlati:

Rettifica valori


Descrizione finestra principale

DESCRIZIONE FINESTRE DEL PANNELLO COMANDI.

Figura 1: finestra iniziale di Rocco

N.B.: in tutta la presentazione si farà riferimento, con numeri e lettere tra parentesi, a comandi e finestre illustrati e codificati in rosso su questa figura 1.

MODULO PRINCIPALE:
  1. Campo titolo da ottimizzare. Lista di tutti i titoli presenti nella tabella nomi del database.
  2. Campo prezzi. Prezzo utilizzato da Rocco per le ottimizzazioni: Apertura, Chiusura Max e Min del giorno. E' consigliabile lavorare sulle chiusure: parametro "C".
  3. Pulsante. Assume colore rosso se il titolo è da ottimizzare, verde se presente nella lista ed ottimizzato almeno una volta. Con un click sul pulsante verde Rocco ricalcola l'indicatore, dopo l'aggiornamento dei dati, e vi dice la posizione attuale (5) e che cosa fare per la successiva apertura del mercato. (6)
  4. Pulsante. Riduce ad icona il programma
  5. Finestra. Posizione attuale (solo per i titoli della lista ottimizzati, dopo aver schiacciato il pulsante verde)
  6. Finestra. Trade da porre in essere all'apertura del mercato successiva. (solo per i titoli della lista ottimizzati, dopo aver schiacciato il pulsante verde)
  7. Finestra. Dopo l'ottimizzazione mostra tutti i risultati ottenuti, in ordine di lavorazione.
  8. OTTIMIZZA. Avvia l'ottimizzazione di un singolo titolo
  9. Interrompi. Interrompe l'ottimizzazione di un singolo titolo
  10. Lista. Apre la finestra "Lista"
  11. Screening. Attiva lo screening giornaliero dei titoli ottimizzati presenti nella lista
  12. Esci. Uscita dal programma
  13. Finestra. Stato dell'ottimizzazione
  14. Console. Apre la console per impostare i range delle medie da ottimizzare
  15. Aiuto. Apre la finestra con le istruzioni
  16. Configura. Apre la finestra di dialogo per l'assegnazione del database su cui lavorare. Al transito del mouse sul pulsante mostra il percorso del database corrente.
  17. Rettifica. Apre la finestra di dialogo per la rettifica o cancellazione dei dati
  18. Cursore e campo data. Imposta il periodo di ottimizzazione
  19. Flag. Attiva o disattiva la possibilità di operare anche short
  20. Campo per l'inserimento delle commissioni permille di negoziazione
  21. Finestra. Evidenzia il miglior risultato e ordina i migliori risultati positivi. Se negativi ne mostra uno solo, il migliore
  22. Pulsante. Apre il rendiconto grafico.
  23. Finestra. Mostra il risultato senza trading

Torna alla pagina iniziale


Lista titoli

LISTA TITOLI.

E' possibile creare e gestire una selezione personale di titoli da ottimizzare e ricalcolare. Cliccando sull'apposito pulsante (12), si apre questa finestra.

Figura 10: La lista

Il pulsante "Carica" serve per leggere nel database i titoli assegnati alla lista in sessioni precedenti.

I titoli che volete inserire nella lista devono essere evidenziati dall'elenco di sinistra e caricati con la freccia singola verso destra; Viceversa per scaricarli dovete selezionarli dalla lista di destra cliccare sulla freccia singola verso sinistra.

Le doppie frecce caricano e scaricano TUTTI i titoli.

Anche qui si può impostare un numero di giorni su cui calcolare l'ottimizzazione; tale numero non deve necessariamente coincidere con quello Visto al punto "Le date".

I parametri di ottimizzazione sono quelli definiti da Console.

Con Elabora parte l'ottimizzazione contemporanea di TUTTI i titoli della lista. NON è possibile interrompere l'elaborazione prima del termine, per cui all'inizio è meglio provare con liste piccole, e capire i tempi di elaborazione. Nella parte inferiore della finestra appaiono i risultati che possono essere anche stampati.

I parametri ricavati dall'ottimizzazione vengono registrati nel database, sono visibili nella finestra "Personalizzata" e rimarranno invariati fino alla prossima ottimizzazione, sul singolo titolo, o lista

Una volta ottimizzati i nostri titoli preferiti, abbiamo quotidianamente bisogno di sapere che cosa fare: comprare, vendere, o stare fermi?. Rocco può rispondere in due modi:

A) Per singolo titolo, selezionando da qui un titolo, presente nella lista e precedentemente ottimizzato, e schiacciando il pulsantino verde.

Se il pulsante è rosso il titolo NON è stato mai ottimizzato e bisogna procedere, prima, all'ottimizzazione.

Come vedete a fianco del pulsantino verde appare la data dell'ultima ottimizzazione, molto importante perché è opportuno ripetere frequentemente, ad esempio una volta la settimana, le ottimizzazioni. Così Rocco si può adeguare a ciò che succede nel mercato.

I segnali sul singolo titolo

Come vedete in questa figura, Rocco, dopo aver cliccato sul pulsante verde, vi dice subito che su questo titolo, siete lunghi e non fate niente. (No Trade)

Al posto di "No Trade" potrebbero apparire

"Next trade: Sell - - - - - - - -" Segnale per Vendere

"Next Trade Buy + + + + + + +" Segnale per Comprare

Queste informazioni le avrete di sera, dopo l'aggiornamento dei dati e quindi sono valide per il giorno dopo, generalmente in apertura.

B) Per tutta la lista di titoli.

Con il pulsante (11), screening, Rocco analizza i titoli della lista e ricalcola le posizioni (utilizzando i parametri definiti dall'ultima ottimizzazione) con i dati aggiornati, fornendo in un unico elenco, che può essere comodamente stampato, i risultati, con le istruzioni operative per ogni titolo presente nella lista.

Una volta impostata la Console come sopra spiegato, per una corretta operatività giornaliera procedere come segue:

  1. Scegliere i titoli che si vuole seguire ed inserirli nella lista;
  2. Effettuare una prima ottimizzazione (da lista)
  3. Aggiornare i dati del database ogni sera, dopo le chiusure (quando i dati sono disponibili)
  4. Lanciare lo screening giornaliero per avere i segnali validi per il giorno successivo.
  5. Settimanalmente ripetere l'ottimizzazione da lista.

Nota: può accadere che, in seguito ad una nuova ottimizzazione, Rocco cambi la sua ultima posizione. Ad esempio nell'ottimizzazione precedente non era nel mercato, dopo la nuova ottimizzazione vi dice che, invece è nel mercato. O viceversa. Consideratelo un segnale e, all'apertura successiva, allineate le Vs. posizioni con quelle del sistema.

Argomenti correlati:

Console

Ottimizzazione

Trading

Note


Il modulo Chart

MODULO CHART

 modulo Chart

E’ un grafico del titolo su cui stiamo lavorando. Con doppio click possiamo ingrandire a tutto schermo, o ripristinare nelle dimensioni, per visualizzare grafici lineari, a barre e candlestick. Possiamo inoltre tracciare e muovere supporti e resistenze, disegnare medie mobili.

Sotto il grafico, oltre ai volumi, vengono visualizzati in modo dinamico, allo scorrere del mouse sul grafico, la data e tutti valori del giorno.

MODULO CHART e RENDICONTO

Scelta del titolo, da utilizzare nel caso si vogliano vedere grafici di titoli presenti nel database di lavoro, anche in modo indipendente dai titoli scelti nella finestra principale.
  • 3 Pulsanti. Tipo di visualizzazione del grafico: L = Lineare, C = Candlestick, B = Barre;
  • Pulsante. Visualizza il cursore a righello;
  • 3 pulsanti. Da sinistra: sposta, elimina e traccia rette.
  • 2 pulsanti. Da sinistra: aggiunge e toglie medie mobili. (la lunghezza va impostata nella finestra di dialogo)
  • Pulsante. Invia il grafico alla stampante predefinita di Windows;
  • Campo e pulsante. Consente di scegliere una durata fra quelle predefinite del grafico, o di impostarne una personalizzata nella finestra di dialogo, che si apre premendo "P".
  • Finestra. Grafico che è possibile usare su tutti i titoli del database indipendentemente dal modulo principale.
  • Finestra. Rendiconto analitico dell'ottimizzazione
  • Finestra. Barre dei volumi.
  • Finestra. Mostra i dati del giorno su cui si trova il mouse: apertura, massimo, minimo, chiusura e volumi.
  • 3 Pulsanti. Da sinistra: aggiunge e toglie griglia verticale, orizzontale ed effettua reset del grafico.

COMANDI NASCOSTI

  • Doppio click all'interno del modulo "Chart" per ingrandirlo a tutto schermo, o ripristinarne le dimensioni.
  • Sul grafico si ottiene l'effetto zoom di un'area, tenendo premuto il pulsante destro del mouse e trascinandolo da sinistra verso destra, lasciando il pulsante dx del mouse una volta coperta l'area desiderata. Per ripristinare la visione iniziale schiacciare il pulsante R del gruppi comando (M).

Argomenti correlati:

Descrizione finestre pannello comandi.

Rendiconto grafico


Disclaimer

Nota:

Questo software e i testi, anche se curati con scrupolosa attenzione, non possono comportare specifiche responsabilità per involontari errori, inesattezze o uso scorretto del programma stesso.

Inoltre i mercati possono salire come scendere e non esistono metodi che ne prevedano l'andamento con certezza.

Gli autori di questo software non possono assumersi responsabilità per perdite conseguenti alle operazioni eseguite sui mercati in relazione all'utilizzo del programma e dei testi.

Infine si ricorda che i risultati conseguiti dal software sui dati passati non forniscono alcun tipo di garanzia per i risultati futuri.


L'ottimizzazione

L'OTTIMIZZAZIONE

Dopo aver regolato (una tantum) i range nella Console, procediamo con l'ottimizzazione, scegliendo il titolo da ottimizzare.

scelta del titolo

Aprendo la tendina, i titoli appaiono in ordine di codice interno al database, che non è, necessariamente, alfabetico.

Digitando le prime lettere, o tutto il nome del titolo che vi interessa, nel campo "Titolo da ottimizzare" e aprendo la tendina con il mouse, oppure schiacciando il tasto freccia in giù sulla tastiera del PC, Rocco si posiziona direttamente sul titolo scelto.

Rocco a questo punto si appropria del titolo e dei relativi dati presenti nel database. Quando nel campo appare il nome del titolo scelto, tutto è pronto.

Rocco lavora dati daily, ossia considera un solo prezzo per giorno. Potete decidere, con la scelta sul campo prezzi, di ottimizzare prezzi diversi da quello di chiusura: apertura, minimo o massimo, ma sempre uno al giorno.

Iniziamo l’elaborazione con il pulsante "OTTIMIZZA"(8). Rocco mostra i parametri impostati. Con OK parte l’elaborazione che ci mostra, nella finestra "risultato" tutte le medie mobili calcolate sulla base dei range impostati e calcola i risultati di tutte le combinazioni possibili. Il criterio usato è quello della negoziazione al primo prezzo successivo disponibile. Quindi se, ad esempio, oggi c’è un segnale di acquisto, il titolo viene acquistato al prezzo di apertura domani, maggiorato delle commissioni impostate. Tutti i risultati vengono visualizzati ancora nella finestra "Risultato" in ordine di durata della media mobile e, in ordine di performance, in un’altra finestra dal nome "Risultati ordinati". Se i risultati fossero tutti negativi ne viene visualizzato solo uno, il meno negativo.

 Risultati Ordinati

Tutti i risultati

il rendiconto.

Basta un solo click su uno dei risultati della finestra "risultati ordinati", "risultato" per aprire il rendiconto contenente analiticamente tutte le operazioni effettuate, l’utile complessivo ed il grado di successo del sistema, ed aprire inoltre il modulo Chart che, ingrandito a piacere, riporta il grafico del titolo e le medie mobili utilizzate per la simulazione.

Il rendiconto può essere stampato con doppio click in qualsiasi punto dello stesso.

Argomenti correlati:

Console

Rendiconto grafico

Lista titoli

Nota


Presentazione generale

PRESENTAZIONE

Rocco è un trading system, cioè un sistema automatizzato per fornire segnali di acquisto e vendita titoli, siamo essi obbligazionari, azionari, valute, o qualunque altra attività finanziaria di largo mercato, ossia tutto ciò che ha un prezzo.

La formula contenuta in Rocco utilizza l’incrocio di due medie mobili esponenziali ed è uno fra i più semplici e sicuri trading system. La sua funzione è ottimizzare, ossia cercare tra tutte quelle possibili, la durata delle due medie mobili che incrociandosi al rialzo, oppure al ribasso, hanno dato i segnali di acquisto e vendita migliori, in termini di rendimento, utilizzando allo scopo le serie storiche di dati memorizzati nel database, che potrà essere mantenuto costantemente aggiornato, per consentirvi di ripetere ed affinare periodicamente l’ottimizzazione. Rocco quindi acquista sul golden cross, ossia quando la media mobile breve perfora al rialzo la lunga e vende nel caso opposto, quando la perforazione avviene al ribasso, sul devil cross.

Rocco va bene per tutti, ma è particolarmente consigliato agli investitori che effettuano operazioni di trading tradizionale (borsino). Esso infatti cerca i trend importanti, quelli che hanno una durata consistente, ed effettua un numero mediamente limitato di operazioni.

Questa nuova versione ha beneficiato di un profondo restyling, che lo rende più immediato e semplice nell'utilizzo. Inoltre sono state inserite nuove funzioni derivate dai sistemi professionali:

· Gestione di liste titoli diverse per ogni database;
· Indicazioni di trading immediate sul singolo titolo, con un semplice click;
· Screening veloce ed automatico, con indicazioni di trading su tutti i titoli presenti nella lista;
· Ordinamento dei risultati sia per miglior esito economico che per numero di operazioni in utile;
· Rendiconto con visualizzazione grafica.

Questa versione, scritta per Windows 9x e successivi, lavora utilizzando una base dati formato Access. Con il modello in dotazione è possibile creare ulteriori archivi per gestire, ad esempio, in modo separato titoli quotati su diversi mercati. Rocco potrà così essere usato su un panorama vastissimo di titoli di quasi tutte le borse del mondo, utilizzando dati scaricati da Internet. (Per maggiori informazioni sui siti vedere l'help di AspToDba).

Il database è residente sul disco fisso del computer, per cui una volta scaricati i dati da Internet, tutte le funzioni di Rocco possono essere attivate velocemente e senza connessioni attive.

Rocco dispone inoltre del modulo Chart , (concepito per mostrare il grafico del titolo e le medie mobili generate dall'ottimizzazione), con il quale si possono tuttavia tracciare in modo indipendente, facile e veloce i grafici di tutti i titoli presenti nel database, anche a schermo intero.

Argomenti correlati:

Descrizione generale comandi

Modulo Chart

Lista titoli

Segnali operativi

Rendiconto


Rendiconto grafico

IL RENDICONTO GRAFICO

Viene visualizzato cliccando sul pulsante presente nella finestra "Risultati ordinati", dopo aver evidenziato, a sinistra del pulsante stesso, il risultato per il quale si vuole vedere il rendiconto grafico.

Eccone un esempio:

esempio di rendiconto grafico.

La figura mostra un grafico a barre del titolo ottimizzato, con le due medie mobili in rosso e verde Le barre verticali azzurre indicano l'entrata e la permanenza nel mercato, quelle verdi l'uscita.

Argomenti correlati:

Ottimizzazione

Lista titoli

Trading

Note


Rettifica dati

RETTIFICA VALORI.

Il pulsante Rettifica (17) serve per correggere i dati di un titolo fino ad una certa data in conseguenza di assegnazioni gratuite (split), aumenti di capitale, raggruppamenti ecc. Il grafico che ne deriva è così "coerente" con i veri movimenti di borsa del titolo e non con i meri prezzi espressi dal mercato.

Figura 12: rettifica

Sulla finestra "Rettifica", si può scegliere:

  • il nome del titolo da rettificare; digitando le prime lettere, o tutto il nome del titolo che vi interessa, nel campo "Nome Titolo" e aprendo la tendina con il mouse, oppure schiacciando il tasto freccia in giù sulla tastiera del PC, Rocco si posiziona direttamente sul titolo scelto e si appropria del titolo e dei relativi dati presenti nel database. Quando nel campo appare il nome del titolo scelto, tutto è pronto.
  • l’intervallo di dati su cui interviene la rettifica (data iniziale e finale comprese).
  • il fattore di rettifica, (che usa il punto quale separatore decimale) ossia il valore per il quale, nel periodo selezionato, vengono moltiplicati tutti i prezzi e divisi i volumi.

Ad esempio Fiat.mi valeva, prima del raggruppamento del 20 agosto 99, circa 3,2 €. Il lunedì successivo Fiat valeva 32 €, cioè 10 volte più del giorno prima, ma in realtà nulla era cambiato nel valore "vero" del titolo: solo furono sostituite 10 vecchie azioni con una sola di nuova. In questo caso il fattore di rettifica era 10, dalla data iniziale, fino al 20/08/99 compreso.
Al termine appare la nota "Rettifica effettuata" e vengono puliti i campi impostati per la rettifica, per evitare che, per errore, si intervenga con una doppia rettifica dei dati.
Infine se volete pulire il vostro database dai dati troppo vecchi e per voi non più significativi, potete usare il tasto cancella dati.
Cancellando TUTTI i dati si elimina anche il nome del titolo dal database.

Se volete pulire il vostro database dai dati troppo vecchi e per voi non più significativi, potete usare il tasto cancella dati. Verranno cancellati tutti i dati, relativi al titolo e per il periodo selezionati. Se vengono cancellati tutti i dati viene rimosso anche il nome del titolo dal database.

N.B.: è opportuno, prima di intervenire con rettifiche o cancellazione dati, fare una copia del database originale, e conservarla per ripristinare dati involontariamente danneggiati da manovre errate. Rocco riappare appena si esce dal modulo rettifica con in pulsante "Esci".

I fattori di rettifica sono disponibili su Internet al sito: http://www.aiaf.it/.

Argomenti correlati:

Il database


I segnali di trading

TRADING

Per vedere la posizione del giorno, selezionate un titolo, precedentemente ottimizzato, e schiacciate il pulsantino verde.

Se il pulsante è rosso il titolo NON è stato mai ottimizzato e bisogna procedere, prima, all'ottimizzazione.

Come vedete in questa figura, Rocco, dopo aver cliccato sul pulsante verde, vi dice subito che su questo titolo, siete lunghi e non fate niente. (No Trade)

Al posto di "No Trade" potrebbero apparire

Next trade: Sell - - - - - - - - Segnale per Vendere

Next Trade Buy + + + + + + + Segnale per Comprare

Queste informazioni le avrete dopo l'aggiornamento dei dati (di solito la sera a mercati chiusi) e quindi sono valide per il giorno dopo, generalmente in apertura.

Figura 8 - Rocco al lavoro

Rocco lavora daily. I segnali di trade arrivano dopo l'aggiornamendo del database, a borse chiuse. Perciò i segnali sono validi per il giorno successivo. Nel rendiconto, affinchè i dati siano omogenei, si è considerato sempre il valore di apertura, appunto del giorno successivo al segnale. Nella finestra a sinistra del pulsante "OTTIMIZZA" sono visibili tutti i risultati dell'ottimizzazione, mentre nella finestra "Risultati ordinati" ci sono solo i migliori risultati (massimo 30, se positivi, uno solo se negativi). Viene sempre evidenziato il "best", che, secondo la scelta fatta da console, sarà per risultato o per percentuale di operazioni positive su negative.

Sulla destra c'è la finestra con il rendiconto dettagliato delle operazioni poste in essere da Rocco per ottenere il risultato "best" evidenziato. Se volete vedere i rendiconti di altri risultati, basta evidenziarli, (un click) così come potete vedere qualunque risultato dell'ottimizzazione, selezionandolo dalla finestra superiore. Analogamente viene aggiornato anche il grafico.

Un click sul pulsante rendiconto grafico qui sotto illustrato, dopo aver evidenziato il rendimento che interessa:

genera un nuovo grafico che riporta visivamente l'attività di trading sul titolo.

Argomenti correlati:

Console

Ottimizzazione

Lista Titoli

Note