Indice

I trading systems

ANDROMEDA

Elenco argomenti trattati nella guida:

  • Presentazione

  • Descrizione finestre e pannello comandi

  • I parametri

  • Gli Stops

  • L'ottimizzazione

  • La lista titoli

  • I Segnali operativi

  • Il trading

  • Il rendiconto analitico

  • Il rendiconto grafico

  • Il timer

  • Il Database

  • Rettifica valori

  • Le date

  • Il Modulo Chart

  • Nota


Console

Torna alla pagina iniziale

CONSOLE d'impostazione PARAMETRI

La prima ottimizzazione deve essere preceduta dall'impostazione dei parametri. Per quelle successive invece il sistema utilizza le impostazioni precedenti.

Per impostare i parametri da ottimizzare cliccate sul pulsante "Console" (16). Si apre questa finestra nella quale vanno impostati i range che saranno utilizzati dal sistema per ottimizzare i tre parametri: il primo indica il tempo minimo/massimo per validare un segnale di trade. I numeri bassi equivalgono a maggior velocità di reazione. Il secondo ed il terzo servono per la costruzione dell'indicatore che è una media mobile adattativa, calcolata su due medie esponenziali. I range da impostare generano le due medie di base. Per ogni parametro sono disponibili due cursori: il primo imposta il valore minimo, mentre il secondo il massimo.

La console

Andromeda quindi simulerà di applicare alla serie storica di dati di ogni titolo tutte le combinazioni possibili, fino a trovare quella che fornisce i risultati migliori. In questo esempio Andromeda calcolerà tutte le combinazioni possibili, a step di uno, partendo da 2,2,2 quindi 2,2,3 ecc. fino ad esaurire le 840 possibilità. Una volta calcolato il risultato migliore, registrerà i parametri che lo hanno ottenuto all'interno del database.

Le impostazioni che vedete nella figura qui a lato garantiscono un buon rapporto tra velocità di esecuzione e qualità dei risultati.
Impostati da "Console" i range vengono memorizzati per tutte le future ottimizzazioni, (lista compresa), fino a vostra successiva modifica.
Una volta acquisita confidenza con Andromeda, potrete impostarli a vostro piacimento, testando tutte le soluzioni che vorrete.

Andromeda è un trading system estremamente sensibile. Per questo potrebbe essere opportuno fargli ignorare il primo segnale di entrata, attendendo così un consolidameno del trend. Viceversa i segnali di uscita, sui quali è meglio non indugiare.

Andromeda vi mostrerà sempre il risultato migliore per rendimento economico, ma potete cambiare se volete il miglior numero di operazioni in utile. Al prossimo utilizzo ritornerà la scelta di default (miglior rendimento).

Argomenti correlati:

Le Date

Ottimizzazione

Lista titoli

Trading


Il database

IL DATABASE

Andromeda, come tutti i nostri programmi che usano dati, si appoggia su una base dati comune scritta in Access. Lo stesso database serve quindi indistintamente per tutto il software RDL & A. Viene così semplificato il lavoro di aggiornamento, dato che si possono utilizzare programmi con funzioni diverse, eseguendo un solo aggiornamento dei dati.

Alla partenza, Andromeda cerca il database su cui lavorare. Se è stato chiuso correttamente ricorda ed utilizza l’ultimo sul quale avete operato. Se non lo trova vi apre una finestra, del tipo "gestione risorse" per consentirvi un’agevole ed intuitiva selezione del file che dovrà essere un database compatibile, come vedremo in seguito al punto "Il Database"

Una volta che avrete evidenziato il database che vi serve, cliccate su "Conferma percorso".

Il database contiene dati "daily": per ogni giorno di trattazione Apertura, Massimo, Minimo e Chiusura ed è composto da due tabelle una che gestisce l'anagrafe dei titoli ed una per i dati.

L'anagrafe contiene il nome di tutti i titoli, ciascuno corredato dal suo codice univoco di riconoscimento e una serie di dati di servizio come la data dell'ultima rettifica dati, l'ultimo fattore di rettifica, i parametri salvati dalle ottimizzazioni dei trading systems, indirizzi di files di sistema ecc.

La tabella dati contiene per ciascuna riga dati un codice di collegamento con la tabella nomi, la data, i quattro dati giornalieri ed i volumi.

Il database fornito in dotazione, Master.mdb, può essere clonato con nomi diversi (con copia e incolla di WIndows) per ottenere un database per ogni mercato. (ad esempio Italy.mdb, Nyse.mdb, France.mdb, ecc.)

AspToDba è stato concepito per automatizzare le operazioni di aggiornamento dati utilizzando files formato testo scaricabili da Internet.

AspToDba ha quindi bisogno di un file in entrata, i dati scaricati da Internet, che vengono letti nel loro formato testo, e aggiorna, in uscita, il Database, nel quale i nuovi dati vengono accodati a quelli già presenti.

Nessun problema se il database è vuoto. AspToDba scrive prima i nomi dei titoli, nella tabella nomi e quindi i relativi dati nella tabella dati. Così la gestione delle anagrafiche titoli è del tutto automatica.

Rimandiamo per ulteriori informazioni all'help di AspToDba.

Argomenti correlati:

Argomenti correlati:

Rettifica valori

Trading


Le Date

LE DATE

Le date

Se il vostro database contiene dati storici di diversi anni, sarà bene escluderne una parte dall’ottimizzazione, sia perché i dati recenti sono i più significativi, sia per aumentare la velocità di elaborazione.
Spostando il cursore si imposta la data da cui Andromeda inizia ad analizzare i prezzi, mentre la data finale corrisponderà sempre all'ultimo dato disponibile;
Se invece volete considerare un segmento temporale di durata prestabilita, ad esempio gli ultimi 200 giorni, (la data iniziale scorre in avanti giorno per giorno) impostate 200 nella casella GG analisi e date OK.
Tali opzioni valgono per tutte le ottimizzazioni, sia quelle da lista che sul singolo titolo.

Argomenti correlati:

Console

Ottimizzazione

Lista titoli


Descrizione finestra principale e comandi

DESCRIZIONE FINESTRE PANNELLO DI CONTROLLO

Finestra iniziale di Andromeda

N.B.: in tutta la presentazione i numeri e le lettere tra parentesi richiamano i campi ugualmente contrassegnati, in rosso, sulla figura qui sopra.

MODULO PRINCIPALE:

  1. Campo titolo da ottimizzare. Il campo elenca tutti i titoli presenti nella tabella nomi del database.
  2. Campo prezzi. Il tipo di prezzo utilizzato da Andromeda per le ottimizzazioni: Apertura, Chiusura Max e Min del giorno. E' consigliabile lavorare sulle chiusure: parametro "C".
  3. Pulsante . Assume colore rosso se il titolo è da ottimizzare, verde se ottimizzato almeno una volta. Con un click sul pulsante verde Andromeda ricalcola la posizione, dopo l'aggiornamento dei dati e fornisce il segnale operativo, visibile nel campo 6, valido per la successiva apertura del mercato. (campo 7). Se il pulsante è rosso non funziona e bisogna prima ottimizzare.
  4. Screening . Attiva lo screening dei titoli ottimizzati presenti nella lista. Perchè funzioni bisogna prima creare la lista e ottimizzarla.
  5. Pulsante. Riduce ad icona il programma
  6. Finestra. Mostra la posizione attuale (solo per i titoli ottimizzati, dopo aver schiacciato il pulsante verde)
  7. Finestra. Operazione da porre in essere all'apertura del mercato successiva. (solo per i titoli ottimizzati, dopo aver schiacciato il pulsante verde)
  8. Finestra. Dopo l'ottimizzazione mostra tutti i risultati ottenuti, in ordine di lavorazione.
  9. OTTIMIZZA . Avvia l'ottimizzazione di un singolo titolo
  10. Personalizzata . Apre una finestra per ottimizzare gli stops o calcolare parametri fissi personali
  11. Interrompi. Interrompe l'ottimizzazione di un singolo titolo
  12. Lista . Apre la finestra "Lista"
  13. Esci. Uscita dal programma
  14. Timer
  15. Finestra. Stato dell'ottimizzazione
  16. Console . Apre la console per impostare i range dei parametri da ottimizzare
  17. Aiuto. Apre la finestra con le istruzioni
  18. Configura . Apre la finestra di dialogo per l'assegnazione del database su cui lavorare. Al transito del mouse sul pulsante mostra il database corrente.
  19. Rettifica . Apre la finestra di dialogo per la rettifica o cancellazione dei dati
  20. Flag. Attiva o disattiva la possibilità di operare anche short
  21. Campo per l'inserimento delle commissioni permille di negoziazione
  22. Campo per impostazione manuale dello stop loss e flag per attivarlo/disattivarlo
  23. Apri. Apre la finestra Stop/Take profit per impostarne i range di ottimizzazione
  24. Campo per impostazione manuale del take profit e flag per attivarlo/disattivarlo
  25. Cursore e campo. Imposta il periodo di ottimizzazione
  26. Finestra. Evidenzia il miglior risultato e ordina i migliori risultati positivi. Se negativi ne mostra uno solo, il migliore
  27. Pulsante. Visualizza il rendiconto grafico.
  28. Finestra. Mostra il risultato senza trading

Argomenti correlati:

Presentazione

Console


Lista titoli

LISTA TITOLI

La lista serve per trattare con un unico comando un gruppo di titoli, sia nella fase di ottimizzazione che per ricevere i segnali di trade, con lo screening giornaliero.

E' possibile creare una selezione personale di titoli, diversa per ogni database. Ciò significa che se usate, per esempio, tre database diversi, (ad esempio per tre mercati diversi), potrete avere tre liste di titoli, una per ogni database. L'inserimento, o la cancellazione di uno o più titoli dalla lista si esegue solo da questa finestra e viene memorizzata automaticamente nel relativo database. Pertanto le liste sono stabili e, una volta create, solo voi potrete modificarle.

 Cliccando sull'apposito pulsante (12), si apre questa finestra.

La lista titoli, finestra iniziale

Il pulsante "Carica" serve per leggere nel database i titoli assegnati alla lista in sessioni precedenti.

I titoli che volete inserire nella lista devono essere evidenziati dall'elenco di sinistra e caricati con la freccia singola verso destra; Viceversa per scaricarli dovete selezionarli dalla lista di destra cliccare sulla freccia singola verso sinistra.

Le doppie frecce caricano e scaricano TUTTI i titoli.

Anche qui si può impostare un numero di giorni su cui calcolare l'ottimizzazione; tale numero non deve necessariamente coincidere con quello descritto al punto "Le date ".

L'ottimizzazione da lista : dopo averla creata e caricata con il pulsante "Carica" avviene in due fasi.
Nota: I parametri usati nell'ottimizzazione sono quelli definiti da Console.

  1. "Ottimizza Parametri" lancia l'ottimizzazione dei tre parametri per TUTTI i titoli della lista.
    Prima di avviare questa parte dell'ottimizzazione è opportuno disattivare gli stops già registrati che, altrimenti condizionerebbero l'ottimizzazione principale. Per evitare che lo dimentichiate, Andromeda chiede se volete disattivare gli stops all'atto dell'avvio della procedura. NON è possibile interrompere l'elaborazione prima del termine, per cui all'inizio è meglio provare con liste piccole, e capire i tempi di elaborazione del vostro PC. Nella parte inferiore della finestra appaiono i risultati che possono essere stampati.

  2. Una volta ottimizzati i 3 parametri si può procedere con "Ottimizza Stop". I range sono quelli definiti nella finestra "console".

La lista titoli durante l'ottimizzzione

Tutti i valori ricavati dall'ottimizzazione vengono registrati nel database, sono visibili aprendo la finestra "Personalizzata" e rimarranno invariati fino alla prossima ottimizzazione, sul singolo titolo, o lista.
I risultati delle ottimizzazioni appaiono nel riquadro in basso e possono essere stampati. Per uscire premere "Chiudi finestra".

Argomenti correlati:

Console

Ottimizzazione

Trading

Nota


Modulo Chart

MODULO CHART

Potete usare Andromeda anche per studiare i grafici dei titoli contenuti nel vostro database. Il modulo può operare in modo indipendente dalla funzione del trading system e può essere aperto a tutto schermo. Ecco un esempio.

Il modulo Chart

Lo potete utilizzare quindi per analisi tecnica elementare su tutti i titoli del database. Con doppio click sull'area del grafico si ingrandisce a tutto schermo, o si ripristina la dimensione iniziale. Visualizza grafici lineari, a barre e candlestick. Potete inoltre tracciare e muovere supporti e resistenze, disegnare medie mobili.

Sotto il grafico, oltre ai volumi, vengono visualizzati in modo dinamico, allo scorrere del mouse sul grafico, la data e tutti valori del giorno.

COMANDI MODULO CHART

  1. Scelta del titolo, da utilizzare nel caso si vogliano vedere grafici di titoli presenti nel database di lavoro in modo indipendente dalla definizione della finestra (1)
  2. Pulsanti. Tipo di visualizzazione del grafico: L = Lineare, C = Candlestick, B = Barre;
  3. Pulsante. Visualizza il cursore a righello;
  4. 3 pulsanti. Da sinistra: sposta, elimina e traccia rette.
  5. 2 pulsanti. Da sinistra: aggiunge e toglie medie mobili. (la lunghezza va impostata nella finestra di dialogo)
  6. Pulsante. Invia il grafico alla stampante predefinita di Windows;
  7. Campo e pulsante. Consente di scegliere una durata fra quelle predefinite del grafico, o di impostarne una personalizzata nella finestra di dialogo.

  8. Finestra. Grafico che è possibile usare anche su tutti i titoli del database Finestra. Mostra i volumi e, sotto, i dati del giorno su cui si trova il mouse.

K. Finestra. Rendiconto analitico dell'ottimizzazione
I. Volumi
 L. 3 Pulsanti. Da sinistra: aggiunge e toglie griglia verticale, orizzontale ed effettua reset del grafico.

COMANDI NASCOSTI

  • Doppio click all'interno del modulo "Rendiconto" per stamparlo;
  • Doppio click all'interno del modulo "Chart" per ingrandirlo a tutto schermo, o ripristinarne le dimensioni.
  • Sul grafico (H) si ottiene l'effetto zoom di un'area, tenendo premuto il pulsante destro del mouse e trascinandolo da sinistra verso destra, lasciando il pulsante dx del mouse una volta coperta l'area desiderata. Per ripristinare la visione iniziale schiacciare il pulsante R del gruppi comando (L).

Argomenti correlati:

Rendiconto analitico

Rendiconto grafico


Disclaimer

NOTA:

Questo software e i testi, anche se curati con scrupolosa attenzione, non possono comportare specifiche responsabilità per involontari errori, inesattezze o uso scorretto del programma stesso.

Inoltre i mercati possono salire come scendere e non esistono metodi che ne prevedano l'andamento con certezza.

Gli autori di questo software non possono assumersi responsabilità per perdite conseguenti alle operazioni eseguite sui mercati in relazione all'utilizzo del programma e dei testi.

Infine si ricorda che i risultati conseguiti dal software sui dati passati non forniscono alcun tipo di garanzia per i risultati futuri.


Ottimizzazione

L'OTTIMIZZAZIONE

Sistemati i parametri nella Console, procediamo con l'ottimizzazione.

Scegliere un singolo titolo da ottimizzare.

Aprendo l'apposita tendina, i titoli appaiono in ordine di codice interno del database, che non è, necessariamente, alfabetico.
Digitando le prime lettere, o tutto il nome del titolo che vi interessa, nel campo "Titolo da ottimizzare" e aprendo la tendina con il mouse, oppure schiacciando il tasto freccia in giù sulla tastiera del PC, Andromeda si posiziona direttamente sul titolo scelto.

Andromeda a questo punto si appropria del titolo e dei relativi dati presenti nel database. Quando nel campo appare il nome del titolo scelto, tutto è pronto.
Con il database fornito Andromeda lavora dati daily, ossia considera un solo prezzo per giorno. Potete decidere, con la scelta sul campo prezzi, di ottimizzare prezzi diversi da quello di chiusura: apertura, minimo o massimo, ma sempre uno al giorno.

Scelta del titolo

Con tutti i parametri e stops a posto, scelto il titolo, iniziate l’elaborazione di un singolo titolo con il pulsante (9) "OTTIMIZZA".

I parametri impostati da Console

Viene proposta questa finestra con i parametri impostati da Console. Se vanno bene dare OK, (altrimenti annullare, chiudere la finestra e ritornare sulla console a reimpostare i parametri.)

Parte il lavoro di ottimizzazione.

E' possibile seguire lo stato di avanzamento del lavoro dalla finestra (15). (stato dell'ottimizzazione)

Per ottimizzare un insieme di titoli con un unico passaggio vedere Lista Titoli.

Argomenti correlati:

I parametri/ Console

Trading

Ottimizzazione della Lista titoli

Segnali operativi


Presentazione generale

PRESENTAZIONE

Andromeda è un trading system "pret-à-porter" (disegnato specificatamente per il trading veloce), ossia un sistema che non necessita, da parte dell'utente di particolari messe a punto, o conoscenze approfondite di analisi tecnica, in quanto contiene un un algoritmo complesso che, ottimizzando tre parametri di sintesi, genera un indicatore di segnali di trade. Testato sul campo ha offerto eccellenti risultati. Il rapporto tra operazioni chiuse positive e negative si è mantenuto mediamente oltre il 50%, ma lo abbiamo visto spesso attorno al 70%. I migliori risultati si sono ottenuti ottimizzando serie storiche di dati comprese tra i sei ed i dodici mesi. Andromeda non cerca i trend primari, ma si limita a farvi stare sul mercato … dalla parte giusta. I risultati ottenuti in "real time" stanno confermando le ottime performances ottenute in backtesting.

Il programma, è stato concepito per assistere gli operatori professionali nella non facile attività di daily-trading. Verificata sul campo l'ottima qualità del sistema, e soprattutto dei risultati, è nata l'idea di offrire anche agli operatori privati una versione "light", ossia una versione semplificata nelle funzioni, nei comandi e, soprattutto, dal costo contenuto. Dopo i primi test della versione Beta, visto l'interesse degli utenti alle funzioni "avanzate", abbiamo deciso di offrire un'unica versione, quella "Professional" allo stesso prezzo contenuto della versione "light", che non verrà commercializzata.

Le funzioni professionali (dettagliatamente descritte più avanti) sono:

  • Simulazione immediata su parametri fissi
  • Operatività long-short
  • Gestione di una lista titoli diversa per ogni database
  • Screening giornaliero veloce ed automatico dei titoli presenti sulla lista
  • Ottimizzazione fine degli stops, con precisione fino al centesimo percentuale
  • Ordinamento sia per miglior risultato economico che per numero di operazioni in utile
  • Rendiconto con visualizzazione grafica
  • Timer per il lancio automatico dello screening giornaliero (presuppone l'aggiornamento automatico del database con interfaccia, - non in dotazione - per modulo DDE dei più diffusi data provider)

Andromeda è quindi un trading system, cioè un sistema automatizzato per acquistare e vendere titoli, siano essi obbligazionari, azionari, valute, o qualunque altra attività finanziaria di largo mercato, ossia tutto ciò che ha un prezzo. E' stato concepito per supportare trades di breve periodo. E' l'ideale per i traders on line che non vogliono (o non possono) dedicare a questa attività più di qualche decina di minuti al giorno.

Questa versione, scritta per Windows 9x e successivi, lavora utilizzando una base dati formato Access. Con il modello in dotazione è possibile creare ulteriori archivi per gestire, ad esempio, in modo separato titoli quotati su diversi mercati. Andromeda potrà così essere usato su un panorama vastissimo di titoli di quasi tutte le borse del mondo, scaricando i dati da Internet. (Per maggiori informazioni sui siti vedere l'help di AspToDba)

Potrete così usare Andromeda su un panorama vastissimo di titoli di quasi tutte le borse del mondo.

Il database è residente sul disco fisso del computer, per cui una volta scaricati i dati da Internet, tutte le funzioni di Andromeda possono essere attivate velocemente e senza connessioni attive.

Andromeda dispone inoltre del modulo Chart, (concepito per mostrare il grafico del titolo e le medie mobili generate dall'ottimizzazione), con il quale si possono tuttavia tracciare in modo indipendente, facile e veloce i grafici di tutti i titoli presenti nel database, anche a schermo intero.

Come funziona

Prima di addentrarci nella presentazione dei singoli comandi, riteniamo opportuno descrivere sinteticamente come opera Andromeda. Abbiamo detto che è un trading system, quindi un sistema che, elaborando dati storici, è in grado di generare un indicatore di trade e modificarlo nel tempo adattandosi al mercato, per fornire quelle che, statisticamente su base storica, si sono rivelate le migliori indicazioni di acquisto e vendita.
Frequenza dei segnali: la base dati su cui lavora Andromeda è daily ossia contiene, per ogni giorno e per ciascun titolo, al massimo i seguenti dati: apertura, massimo, minimo, chiusura e volume. Quindi, per ogni titolo è possibile un solo segnale al giorno. Tale segnale potrà essere: Buy, o Sell, o No-Trade. Andromeda, pur fornendo al massimo un segnale di trade al giorno è un trading system piuttosto veloce.
Il numero di operazioni consigliate per ogni singolo titolo è variabile in funzione del trend ma la durata degli investimenti va da un giorno a qualche settimana. E' quindi un trading system adatto a chi usa il trading on line che di solito ha commissioni bancarie di negoziazione contenute.
Timing dei segnali: le indicazioni arrivano sempre a mercati chiusi, dopo l'aggiornamento del database, e sono valide per il giorno successivo. Per comodità si può scegliere di operare sempre in apertura (quella successiva al segnale).
Utilizzando questo sistema il tempo da dedicare al trading viene drasticamente ridotto. Per dare un'idea del lavoro richiesto per fare trading con Andromeda, elenchiamo le attività da porre in essere. Con queste semplici operazioni sarete già in grado di seguire metodicamente un numero di titoli che vi consentirà investimenti con un buon livello di diversificazione su qualsiasi mercato.

Serve un database aggiornato contenente almeno un anno di dati. Il database può essere creato in pochissimo tempo, ed aggiornato in qualche minuto, usando AspToDba, (fornito con Andromeda). Le istruzioni sull'uso di AspToDba sono contenute nella relativa presentazione.

Attività una tantum:

  1. Create il vostro database. (vedi AspToDba);
  2. Impostate i parametri, gli stops ed il periodo da ottimizzare;
  3. Create una lista dei titoli che volete seguire

Attività periodica: (Ad esempio una volta alla settimana):

  1. Eseguite le ottimizzazioni dei titoli della lista: prima i parametri, e poi gli stops. Tutti i valori calcolati vengono memorizzati nel database, fino alla successiva ottimizzazione.

Attività quotidiana:

  1. Ogni sera, a mercati chiusi, aggiornate i dati e fate partire lo screening. Andromeda produrrà una tabella contenente i titoli presenti nella lista, con la relativa posizione (titolo in portafoglio, o meno) e le indicazioni operative per ciascuno. (buy, sell, no-trade). Ora sapete che cosa fare appena apriranno i mercati.
  2. La mattina dopo, in apertura, fate gli ordini.

Argomenti correlati:

Console

Database

Ottimizzazione

Segnali operativi

Nota


Rendiconto analitico e grafico

IL RENDICONTO ANALITICO

Ogni volta che si ottimizza, oppure che si chiede la posizione con il pulsante verde, Andromeda ricalcola il rendiconto e lo evidenzia nella finestra "Rendiconto".

Finestra di lavoro di Andromeda con rendiconto anaitico

Il rendiconto analitico descrive tutte le operazioni riferibili al risultato evidenziato nella finestra "risultati ordinati" in basso a sinistra. E possibile vedere il rendiconto relativo anche agli altri risultati facendo doppio click sugli stessi.

I risultati ordinati sulle migliori 30 ottimizzazioni appaiono solo quando si ottimizza il singolo titolo, e non da lista o da richiesta posizione (con pulsante verde).

Il rendiconto analitico può essere stampato con doppio click in qualsiasi punto dello stesso.

Argomenti correlati:

Ottimizzazione

Lista titoli

I segnali di trade

Nota


RENDICONTO GRAFICO

Cliccando sul pulsante [image] , dopo aver ottimizzato il singolo titolo, o dopo aver ricalcolato la posizione con il pulsante verde, lanciate il rendiconto grafico che riporta visivamente tutte le operazioni descritte nel rendiconto analitico.

Le barre verticali azzurre, indicano il giorno dell'entrata e la permanenza nel mercato; quelle verdi il giorno dell'uscita.

Esempio di rendiconto grafico

Esempio di rendiconto grafico.

Argomenti correlati:

Ottimizzazione

Screening

Rendiconto analitico

Modulo Chart


Rettifica dati

RETTIFICA VALORI.

Il pulsante (19) apre la finestra "Rettifica" che serve per la manutenzione dei dati, ad esempio correggere i prezzi di un titolo fino ad una certa data in conseguenza di assegnazioni gratuite (split), aumenti di capitale, raggruppamenti ecc. Il grafico che ne deriva è così "coerente" con i veri movimenti di borsa del titolo e non con i meri prezzi espressi dal mercato. Ad esempio Fiat.mi valeva, prima del raggruppamento del 20 agosto 99, circa 3,2 €. Il lunedì successivo Fiat valeva 32 €, cioè 10 volte più del giorno prima, ma in realtà nulla era cambiato nel valore "vero" del titolo: solo furono sostituite 10 vecchie azioni con una sola di nuova.

Sulla finestra "Rettifica", si può scegliere:

  • il titolo da rettificare;
  • l’intervallo di dati (compresa la data iniziale e finale) su cui interviene la rettifica
  • il fattore di rettifica, (che usa il "punto" quale separatore decimale) ossia il valore per il quale, nel periodo selezionato, vengono moltiplicati tutti i prezzi e divisi i volumi.

Nell’esempio di Fiat il fattore di rettifica era 10, dalla data iniziale, fino al 20 agosto 99.

Al termine appare la nota "Rettifica effettuata" e vengono puliti i campi impostati per la rettifica, per evitare che, per errore, si intervenga con una doppia rettifica dei dati.
Infine se volete pulire il vostro database dai dati troppo vecchi e per voi non più significativi, potete usare il tasto cancella dati.
Cancellando TUTTI i dati si elimina anche il nome del titolo dal database (e quindi anche dalla lista).

Finestra "Rettifica"

N.B.: è opportuno, prima di intervenire con rettifiche o cancellazione dati, fare una copia del database originale, e conservarla per ripristinare dati involontariamente danneggiati da manovre errate. Andromeda riappare appena si esce dal modulo rettifica con l’apposito pulsante. I fattori di rettifica sono disponibili su Internet al sito: http://www.aiaf.it/ .

Argomenti correlati:

Il database


I segnali di trade

I SEGNALI OPERATIVI

Dopo l'ottimizzazione dei vostri titoli preferiti, avrete quotidianamente bisogno di sapere che cosa fare: comprare, vendere, o stare fermi?. A queste domande Andromeda può rispondere in tre modi:

A) Segnale sul singolo titolo ottimizzato: selezionando un titolo, precedentemente ottimizzato, schiacciate il pulsante verde.

Il pulsante è rosso e non funziona quando il titolo selezionato NON è stato mai ottimizzato. Per farlo diventare verde bisogna, prima, ottimizzare i parametri.

Come vedete a fianco del pulsante verde appare la data dell'ultima ottimizzazione, molto importante perché è opportuno ripetere periodicamente, ad esempio una volta la settimana, le ottimizzazioni. Così Andromeda è informato di quello che succede nel mercato.

I segnali sul singolo titolo

Come vedete nella figura, Andromeda vi dice che avete questo titolo in portafoglio (posizione lunga) e non dovete fate niente. (No Trade)
Al posto di "No Trade" potrà apparire
Next trade: Sell - - - - - - - - - - - Segnale per Vendere, oppure
Next Trade Buy + + + + + + + Segnale per Comprare

Queste informazioni le avrete di sera, dopo l'aggiornamento dei dati e quindi sono valide per il giorno dopo, in apertura.

I segnali sul singolo titolo

B) Segnale su un singolo titolo non ottimizzato: impostate manualmente i tre parametri di Andromeda nella finestra "Personalizza Parametri":

Personalizza Parametri: questa finestra si apre cliccando sul comando "Personalizzata" della finestra principale (10) e appare con i parametri in bianco solo per i titoli mai ottimizzati; per gli altri riporta i valori dell'ultima ottimizzazione registrati nel database. Può essere utilizzata per:: questa finestra si apre cliccando sul comando "Personalizzata" della finestra principale (10) e appare con i parametri in bianco solo per i titoli mai ottimizzati; per gli altri riporta i valori dell'ultima ottimizzazione registrati nel database. Può essere utilizzata per:

    • ottimizzare e registrare nel database gli stops su un singolo titolo. Nel caso il database contenga altri valori di stop, questi vengono sovrascritti.

    • visualizzare il rendiconto di parametri personali particolari, che serviranno unicamente per il calcolo dello stesso rendiconto, ma non verranno memorizzati nel database

Personalizzata

C) Segnale su un elenco di titoli (Screening lista di titoli).

Esempio di risultati dello screening

Con il pulsante (4), Screening, Andromeda cerca i titoli della lista e ricalcola la posizione per ciascuno (utilizzando i parametri definiti dall'ultima ottimizzazione) con i dati aggiornati, fornendo un unico file contenente le istruzioni per ogni titolo presente nella lista.

Accanto alle posizioni aperte e agli ordini ci sono dei simboli, come "*******" , "- - - - -" e "+ + + + + +" per rendere meglio visibile, in uno screening contenente molti titoli le posizioni attive e le operazioni consigliate.

Nota importante:

può accadere che, in seguito ad una nuova ottimizzazione, Andromeda cambi la sua ultima posizione. Ad esempio nell'ottimizzazione precedente non era nel mercato, dopo la nuova ottimizzazione vi dice che, invece è nel mercato. O viceversa. Consideratelo un segnale e, all'apertura successiva, allineate le Vs. posizioni con quelle del sistema.

Argomenti correlati:

Gli Stops

Ottimizzazione

Lista titoli


Commissioni bancarie e Stop Loss

STOPLOSS e TAKE PROFIT

Cosa sono:

Andromeda prevede l'utilizzo e l'ottimizzazione di stop loss e take profit, ossia i livelli massimi di perdita o guadagno per un dato titolo, in percentuale sul prezzo. Lo stop loss è stato disegnato seguendo la famosa massima "taglia le perdite e lascia correre i profitti". In caso di mercato al rialzo lo stop loss segue il prezzo del titolo, e viene calcolato sul prezzo più alto toccato in chiusura consentendo, in caso di inversione del trend un consolidamento dei guadagni. Viceversa, in caso di ribasso, lo stop rimane ancorato al prezzo di acquisto e non vi consentirà di rimanere sul mercato oltre il livello massimo di perdita prestabilita. Il take profit invece parte dal vostro prezzo di acquisto e vi fa uscire al raggiungimento del target di utile.
Andromeda è estremamente flessibile con gli stops. Potete decidere di lavorare senza, con uno solo o entrambi attivati, inoltre potete usare sia stops "tecnici", ossia i migliori possibili, calcolati da ottimizzazione, che gli stops "finanziari", equivalenti alle perdite massime che voi siete disposti a subire su un titolo indipendentemente dai segnali tecnici. I primi vengono calcolati dal trading system (da ottimizzazione su singolo titolo, o da lista), dopo l'ottimizzazione degli altri parametri mentre i secondi si devono impostare dalle finestre (22) e (24) prima dell'ottimizzazione di un singolo titolo (non da lista) e non vengono memorizzati. Infine è possibile il compromesso, impostando il vostro stop finanziario quale valore massimo di range degli stops da ottimizzare. Ne risultarà uno stop tecnico certamente non superiore a quello finanziario.

Come si usano:

  • Si possono applicare stops finanziari in fase di ottimizzazione dei singoli titoli, attivando i flags accanto ai campi (22) e (24) e impostando prima dell'ottimizzazione nella finestra Stop/Takeprofit il livello dello stop desiderato uguale al valore minimo e massimo del range. In quanto stops finanziari, si tratta di range senza possibilità di escursione, ad esempio da 5 a 5. Naturalmente quando si procede con l'ottimizzazione NON si deve disabilitare gli stops. In questo modo non vengono ottimizzati gli stops, ma solo la media adattativa di Andromeda tenendo però conto degli stop imposti.

  • Si possono ottimizzare gli stops su un singolo titolo, (stops tecnici) dopo averne ottimizzato i parametri di Andromeda. In questo caso, dopo l'ottimizzazione di Andromeda):

  1. si attivano i flags degli stop

  2. si apre la finestra per impostare i range degli stops

  3. si apre la finestra "Personalizzata" e si clicca su "Ottimizza Stop/Takeprofit".

  • Si possono calcolare stops (finanziari o tecnici) a tutta la lista di titoli. Se volete stops finanziari impostate range fissi uguali al livello di stop che desiderate, (ad esempio da 5 a 5), invece per quelli tecnici inserite dei range entro i quali il sistema possa cercare i valori migliori possibili. Quindi aprite la lista e ottimizzateli con l'apposito pulsante.

  • Si possono applicare stops finanziari ad un rendiconto dopo l'ottimizzazione dei parametri di Andromeda, ad esempio per vederne di quanto cambia il rendiconto stesso con quegli stops: dopo aver scritto manualmente nelle caselle (22) e (24) i livelli di stop desiderati, cliccate sul pulsante verde. Tali forzature manuali non vanno a sovrascrivere gli stops elaborati nell'ottimizzazione da lista, per cui la prossima volta che richiamate il titolo appariranno i valori calcolati nell'ottimizzazione precedente.

  • StopLoss e Takeprofit possono essere disattivati entrambi o uno solo deselezionando gli appositi flags a destra delle caselle (22) e (24)

Range su Stop Loss e Take Profit

Range di Stop/Takeprofit
per la successiva ottimizzazione

Il pulsante (23) apre questa finestra di dialogo, nella quale vanno inseriti i valori minimo e massimo (range) all'interno dei quali Andromeda ottimizzerà, per "Step", sia lo stop loss che il take profit.
In questo esempio cercherà due valori (percentuali), compresi tra uno e quindici, (a step di uno, quindi 1,2,3,ecc) che applicati, uno come stop loss ed uno come take profit, riusciranno a migliorare il risultato dell'ottimizzazione.
I risultati dell'ottimizzazione vengono registrati nel database e tali rimarranno fino alla prossima ottimizzazione. Se l'ottimizzazione degli stops non dovesse interessare, una volta che sono registrati nel database, possono essere disattivati solo con gli appositi flag posti accanto ai campi (22) e (24).
Lo step minimo è ridotto a 0,01 (%) per consentire l'applicazione degli stops anche a titoli poco volatili, come ad esempio, quelli a reddito fisso (BTP).

Altre personalizzazioni di Andromeda:

E' possibile inoltre impostare Andromeda per:

  1. Consentire vendita allo scoperto: attivato = SI
  2. Calcolare le commissioni permille pagate all'intermediario su ogni operazione di acquisto o vendita, ai fini del rendiconto.

Commissioni, Stop Loss e Take profit

Argomenti correlati:

Ottimizzazione

Lista titoli

Console


Timer

IL TIMER

Alcuni operatori dispongono di programmi per la lettura dei dati di mercato e l'aggiornamento automatico del database.

Per loro è stato reso disponibile il Timer che, ad un'ora prestabilita, (successiva all'aggiornamento del database) fa automaticamente partire lo screening dei titoli presenti nella lista.

Al mattino successivo sul PC sarà automaticamente disponibile l'evidenza delle operazioni da porre in essere.

Argomenti correlati:

Screening

Lista titoli


Trading

TRADING

Andromeda lavora daily. I segnali operativi arrivano dopo l'aggiornamento del database, a borse chiuse. Perciò i segnali sono validi dall'apertura di borsa successiva. Nel rendiconto, affinchè i dati siano omogenei, il programma considera sempre il valore di apertura, appunto del giorno successivo al segnale. Nella finestra (8) sono visibili tutti i risultati dell'ottimizzazione, mentre nella finestra (26) ci sono solo i migliori risultati (massimo 30 se positivi, mentre se sono tutti negativi ne appare uno solo). Viene sempre evidenziato il "best", che, secondo la scelta fatta da console, sarà il migliore per risultato economico, o per percentuale di operazioni positive su negative.
A destra, sulla finestra (K) c'è il rendiconto dettagliato di tutte le operazioni poste in essere da Andromeda per ottenere il risultato "best" evidenziato. Se volete vedere il rendiconto di altri risultati, basta evidenziarli (con un click), così come potete vedere qualunque risultato dell'ottimizzazione, selezionandolo dalla finestra (8) .Analogamente viene aggiornato anche il grafico (H) Inoltre il pulsante (27) genera un nuovo rendiconto grafico che riporta visivamente l'attività di trading del "best" o di qualunque altro risultato selezionato dalla finestra "Risultati Ordinati"

I segnali possono essere chiesti al sistema in tre modi:

  • Su un singolo titolo già ottimizzato

  • Su un singolo titolo non ottimizzato, impostando manualmente i tre parametri di Andromeda;

  • Per una selezione di titoli (Lista) già ottimizzati

Per approfondire l'argomento rimandiamo a "Segnali di trading"

Argomenti correlati:

Console

Ottimizzazione

Lista Titoli

Database

Nota