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Using VirtualDub to edit and recompress videos made by cameras like 
MD-80 or 808 KeyChain  
 
Live long and prosper. 
 
I do not pretend to teach anything to anyone, but I hope to give some suggestions to help those unfamiliar with the program.  
 
My scope is to help people who want to change (e.g. duration or remove timestamp) and then recompress videos, such as 
DivX. 
The videos produced by the cameras are usually compressed in MPEG-4 (standard DVD) and are very large.  
 
Here are the steps to follow. I’ve written which are mandatory and which optional.  
 

INSTALLING VirtualDub (required)  
Go to this webpage and download VirtualDub:  
http://virtualdub.sourceforge.net/ 
Search the first link:  
List download mirrors for Vx.xx (32-bit) release build. 
It’s not a program to be installed. Simply unzip the downloaded archive in the folder you want.  
I've put it here: C:\Program Files\VirtualDub and I made a link to VirtualDub.exe on desktop for convenience.  
 

DOWNLOAD PLUG-IN TO REMOVE TIMESTAMP (optional)  
Open this webpage:  
http://www.aircommandrockets.com/md80clone.htm 
and download the file:  
timestamp.vdf 
(Thanks to George) 
Once downloaded, copy it here:  

C:\Program Files\VirtualDub\plugins (where C:\Program Files\VirtualDub\ is the path where you extracted the archive above)  
An alternate filter to remove the timestamp is called Logoaway and can be found here: 
http://voidon.republika.pl/virtualdub/ 
(Thanks to Krzysztof Wojdon) 
 

DOWNLOAD DivX CODEC (optional if already installed)  
Open this page:  
http://www.divx.com/en/software/divx-plus 
and press the Free Download button (green).  
Once downloaded, install it.  
 
 
Excellent: we are ready to begin. 
 

QUICK TOUR TO VirtualDub INTERFACE  
At first sight, VirtualDub seems a bit tough. 
In fact it is not provided by windows and small buttons, features of immediate use programs. The important thing is not 
demoralized, try and try. 

 
 

 
In the picture you can see: 
1) Menu File where you can open file and save processed files. 
2) Menu Edit where you can cut, copy and paste parts of video. 
3) Menu View where you can configure preview and other options. 
4) Menu Video where you can configure video filters and video compressor. 
5) Menu Audio where you can configure audio filters and audio compressor. 
6) Commands to control position and playback. 
7) Buttons to set the beginning and end of selection.  

http://virtualdub.sourceforge.net/
http://www.aircommandrockets.com/md80clone.htm
http://voidon.republika.pl/virtualdub/
http://www.divx.com/en/software/divx-plus
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OPEN AVI FILE (required)  
After opening VirtualDub, click the menu item File -> Open Video File  
Look for your video and open it. 
Now you should see the video duplicated: left is the original one. The right is the one generated by VirtualDub.  
Right now they are identical (as shown above).  
If the video out the window of VirtualDub, you can automatically adjust the menu option View -> Layout Pane -> Auto-Size 
Panes (do not recommend it, otherwise you will not appreciate final quality and details)  
 

INFORMATION ON THE ORIGINAL VIDEO (optional) 
It may have just opened the file information from the File Menu -> File Information....  

 
 

 
From here you can read format of the source video. 
For example, it is interesting to see that the bitrate is 8290kbps. Very high, because the file is large. 
Compressing to DivX you have a good quality at 2000kbps already. So the final file will be 1/4! 
Another fact: the audio is not compressed, has a sampling frequency of 22,050 Hz and it is mono. 
 

CUT THE VIDEO (optional) 
There are several ways to do this. The simplest is the one I describe here.  

 
 

 
1) Find the point where you want to begin the video. To do this, use commands directly feed the bottom or drag the slider. In 
my video, I cut the model preparation. 
2) Press the button with the black left pointing arrow (tip says [In Mark]). This marks the selection start.  
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3) Same way, find end point. In my video, I cut the model crash (no joke, I seriously crashed my model when I did the video 
for this tutorial!!!). 
4) Press the last button with black right pointing arrow (tip says [Mark Out]). This marks the selection end.  
The selection appears in blue. 
Leaving everything as it is, VirtualDub will convert only the selected part.  
 

REMOVE TIMESTAMP WITH Timestamp Remover (optional)  
If you have not already done so, Video Menu -> Full Processing Mode. This is to activate menu items such 
as Filters and Compression....  

 
 

 
Video menu -> Filters.  

 
 

 
Opened window will contain all filters to be applied to video. Currently there are no active filters. Press the Add... button. 
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Select Timestamp Remover in the list and press OK. 

 
 

 
If you have a camera MD-80 clone or 808 type #3 (date and time yellow bottom right), in this window leave everything as is. 
Otherwise it is necessary to adjust settings depending on the size, position and color of the date and time generated by the 
camera.  
Press OK and you will see the configured filter to appear in the filter list. 

 
 

 
If there is more than one filter, this one should be first on the list. You can use the Move Up and Move Down buttons to adjust 
filters order. 
 

REMOVE TIMESTAMP WITH Logoaway (optional) 
This method is an alternative to the previous one. Choose the one that is more satisfying.  
Video Menu -> Full Processing Mode. 
Video menu -> Filters. 
Opened window will contain all filters to be applied to video. Currently there are no active filters. Press the Add... button.  
Choose Logoaway from the list and press OK.  
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In this window, set the Logo border position and Logo border size. Above the example for MD-80 clone and 808 type #3 
cameras. 
In Remove mode choose the method you like. 
Preview of effect can be seen by clicking Show preview. 
Press OK. You will see configured filter to appear in filters list.  
If there is more than one filter, this one should be first on the list. You can use the Move Up and Move Down buttons to adjust 
filters order. 
 

RESIZE VIDEO (optional)  
As you know, many cameras produce videos in 720x480 although nearly all the sensors are 640x480. The result is a distorted 
picture (enlarged). 
You can bring the video to the native resolution of the sensor as follows.  
Video Menu -> Full Processing Mode. 
Video menu -> Filters. 
Press the Add... button. 
Choose Resize from the list and press OK. 
 

 
1) Aspect Ratio - Compute from height ratio: 4:3 (or disabled, so you have maximum freedom)  
2) New size - Absolute (pixels) 
3) 640x480 (or size you want).  
Leave Filter mode as is. It actually doesn’t affect final quality when you decrease the resolution instead of increasing it.  
Press OK and the filter will appear in the filter list. 
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After setting the filter, you will see the effect in real time right in the video. 

 
 

 
In this picture you can see that the timestamp has been removed and the video has a good aspect ratio and is not distorted (it 
is slightly narrower than the original). 
You can try to drag cursor or start playback or to see the filters effect along different parts of the video.  
 

SET FRAMERATE (required)  
To allow the DivX compressor to work properly, it is strictly necessary that framerate is an integer (e.g. 24 or 25 or 30, NOT 
30.999)  
Video Menu -> Frame Rate....  
Here you can choose between the Source Rate Adjustment or the Framerate conversion.  
Source Rate Adjustment: changes only the timing but you could have a mismatch between audio and video in long videos 

 
Framerate conversion: adjusts the video to meet our requirements. I usually use this. 
 

 
Configuration will be:  
Source Rate Adjustment: No change. 
Framerate Conversion: Convert to fps: 30 (or 25 if you prefer). 
Then click OK.  
 

CONFIGURE CODEC (required)  
Video Menu -> Full Processing Mode. 
Video Menu -> Compression .... 
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Find and click DivX x.x.x Codec (x Logical CPUs). 
Then Configure.  

 
 

 
Certification Profile: Home Theater Profile  
Encoding presets: move the cursor up to 8  
Rate control mode: 1-pass  
Bitrate: here, higher is the number, higher is the quality and larger the final file. Max is 4854 kbps. To decide how to set, 
perform different tries.  
Then press the Advanced button. 
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Remove option Do not prompt with errors and warnings. This way, if the codec fails, you are informed about the reason.  
Confirm all dialogs with OK. 
 

MODIFY AUDIO (optional)  
Here I describe, for example, how to convert the audio from mono to stereo and add a chorus, so you have a stereo effect. 
Fake, but realistic. 
If you do not want to change the audio,  Audio menu -> Direct Stream Copy. VirtualDub will use the audio track exactly as 
the original. 
If you want to change the sound: Audio Menu -> Full Processing Mode. (This activates menu items for processing audio). 
Audio menu -> Use advanced filtering (if not already active) 
Audio menu -> Filters.... 

 
 

 
This window shows connections between audio filters. For now it is empty. 
Press Add.  
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Press in sequence: 
1) Input 
2) Add 
3) Stereo Chorus 
4) Add 
5) Output 
6) Add 
7) Close 
You will obtain the filter connected to audio source (input) and processed audio (output).  

 
 

 
Graphic connection between the various filters used will be shown. You can add filters as you like and change the connections 
(arrows) as desired. 
Use Test button and the scroll bar below to verify that configuration works and what will be the final effect. Test button starts 
or stops processed audio playback. 
 

AUDIO COMPRESSION (optional)  
In Full processing mode, audio can be compressed. 
Audio menu -> Compression....  
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Set: 
1) MPEG Layer-3 commonly known as MP3 ;-) 
2) Show all formats 
3) Choose a format consistent with your sound. 
The example was converted to stereo, so search this group and not mono. Sound source was 22050 Hz, then choose the one 
that has 22,050 Hz sampling rate and higher bitrate (higher quality). 
Click OK.  
 

SAVE THE FILE (obviously required)  
Menu File -> Save as AVI  
 
Give a different file name from the original! 
 

HOW TO CREATE HIGH QUALITY VIDEO FILES 
DivX compression described above (single pass) is a compromise between encoding speed and final quality. 
If you want to get higher quality, you can use another method but it takes more time (but same file size!). It is called multi-
pass. 
First pass analyzes the video; each further pass encodes improving quality. 
Pass 1: Analysis; pass 2: encoding, pass 3: increase in quality compared to pass 2, etc... 
Each pass takes the whole encoding time. So, to perform three passes (one analysis pass + two coding passes), it will take 
three times the time elapsed by the single-pass method. 
Already in pass 2, quality is better than the single-pass method. 
From the fourth pass (included), increasing of quality is not noticeable. So I suggest doing only three passes (one analysis 
pass + two coding passes). 
It is very important to change not any settings between passes.  
The following steps describe this method. 
1) Menu Video -> Compression.... 
2) Select the DivX codec and press Configure. 
3) Rate control mode: Multipass, 1st pass (the previous method was 1-pass). Confirm all dialogs with OK. 
4) Menu File -> Save as AVI. This is merely performing the analysis. The. AVI is unusable. First pass. 
5) Proceed with the analysis (it's just like a normal encoding with preview) 
6) Menu Video -> Compression.... 
7) DivX codec should already be selected. Press Configure. 
8) Rate control mode: Multipass, nth pass. Confirm all dialogs with OK.  
9) File Menu -> Save as AVI. You should give same name as before overwriting the file. This is the first real coding and it is 
the second pass. 
If you want to make a third pass just re-do step 9. Avoid fourth or fifth pass (not strictly necessary to increase quality). 
 

OTHER SUGGESTIONS  
VirtualDub is a very powerful tool and can do things like cutting out the frame, adjust brightness and contrast and other things 
much more complicated. 
You can also deeply modify the sound track. For example, when you edit video taken by more cams at once and you want to 
have a true stereo effect, you can change audio from mono to stereo in left or right channel only.  
 
 
I hope this tutorial can be helpful.  
 
Willy 
(sorry for my bad English: I’m Italian) 
You can contact me sending a private message to Willy163 on http://www.rcgroups.com/ or http://www.baronerosso.eu/  
 
 
Many thanks to: 
Chuck Lohr  http://chucklohr.com/ 

http://www.rcgroups.com/
http://www.baronerosso.eu/
http://chucklohr.com/
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